Bug 1017580 - RBAC: intermittent failures of RBACProviderServerGroupScopedRolesTestCase
RBAC: intermittent failures of RBACProviderServerGroupScopedRolesTestCase
Status: CLOSED DUPLICATE of bug 1024072
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ladislav Thon
Ladislav Thon
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 04:11 EDT by Ladislav Thon
Modified: 2013-12-15 08:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 03:56:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladislav Thon 2013-10-10 04:11:27 EDT
The domain test suite for RBAC is consistently failing on SPARC Solaris, as can be seen at https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-62-RBAC-QE-testsuite-Solaris-matrix/

Given that all the tests are running against the same domain, the first failure is the most significant and the others are just symptoms of inconsistent test environment.

The first failure looks like this:

Failed: {
    "address" => [
        ("core-service" => "management"),
        ("access" => "authorization"),
        ("role-mapping" => "MainGroupDeployer"),
        ("include" => "user-MainGroupDeployer")
    ],
    "operation" => "remove"
}
Result: {
    "outcome" => "failed",
    "result" => undefined,
    "failure-description" => "JBAS010839: Operation failed or was rolled back on all servers.",
    "rolled-back" => true,
    "server-groups" => {
        "server-group-a" => {"host" => {"master" => {"master-a" => {"response" => {
            "outcome" => "failed",
            "rolled-back" => true,
            "response-headers" => {"process-state" => "restart-required"}
        }}}}},
        "server-group-b" => {"host" => {"slave" => {"slave-b" => {"response" => {
            "outcome" => "failed",
            "failure-description" => "JBAS014807: Management resource '[
    (\"host\" => \"slave\"),
    (\"server\" => \"slave-b\"),
    (\"core-service\" => \"management\"),
    (\"access\" => \"authorization\"),
    (\"role-mapping\" => \"MainGroupDeployer\"),
    (\"include\" => \"user-MainGroupDeployer\")
]' not found",
            "rolled-back" => true,
            "result" => undefined
        }}}}}
    }
}

and it happens when tearing down the test environment, as can be seen from the stacktrace:

java.lang.AssertionError: JBAS010839: Operation failed or was rolled back on all servers.
	at org.junit.Assert.fail(Assert.java:88)
	at org.jboss.as.test.integration.management.rbac.RbacUtil.checkOperationResult(RbacUtil.java:94)
	at org.jboss.as.test.integration.management.rbac.RbacUtil.executeOperation(RbacUtil.java:79)
	at org.jboss.as.test.integration.management.rbac.RbacUtil.removeRoleUser(RbacUtil.java:152)
	at org.jboss.as.test.integration.management.rbac.UserRolesMappingServerSetupTask.tearDown(UserRolesMappingServerSetupTask.java:84)
	at org.jboss.as.test.integration.domain.rbac.RBACProviderServerGroupScopedRolesTestCase.tearDownDomain(RBACProviderServerGroupScopedRolesTestCase.java:59)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
	...

The same can be seen at:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-62-RBAC-QE-testsuite-Solaris-matrix/jdk=java16_default,label=sol11_sparc/3/testReport/junit/org.jboss.as.test.integration.domain.rbac/RBACProviderServerGroupScopedRolesTestCase/org_jboss_as_test_integration_domain_rbac_RBACProviderServerGroupScopedRolesTestCase/

More details can be found in the job workspace, specifically in testsuite/domain/target:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-62-RBAC-QE-testsuite-Solaris-matrix/jdk=java16_default,label=sol11_sparc/ws/jboss-eap/testsuite/domain/target/

I'm assigning to myself, as this is most likely a test issue, though it might have something in common with https://issues.jboss.org/browse/WFLY-2270
Comment 2 Ladislav Thon 2013-10-21 06:06:28 EDT
Renaming the issue to point out that:

- this is not only failing on Solaris SPARC, but also on Windows
- it's a single specific test that is failing

I've created a Job to run just this single test: https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-62-RBAC-testsuite-Solaris-investigation/

I can only guess that the test is failing in a very slow environment, which might mean that either there is a small timeout somewhere in the test, or that there is some concurrency issue in the code. I wasn't able to reproduce the failure manually yet.
Comment 3 Ladislav Thon 2013-11-04 03:56:58 EST
Turns out this was caused by bug 1024072. I reran the test with EAP 6.2.0.ER6, which contains the fix, and it passed. Closing as dupe.

*** This bug has been marked as a duplicate of bug 1024072 ***
Comment 4 Ladislav Thon 2013-11-04 03:58:28 EST
(Bleh. That was of course ER7. Silly me.)

Note You need to log in before you can comment on or make changes to this bug.