Bug 1017604 - LD_LIBRARY_PATH does not contain 32bit lib path on 64bit systems
LD_LIBRARY_PATH does not contain 32bit lib path on 64bit systems
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: devtoolset-meta (Show other bugs)
DTS 2.0 RHEL 6
All Linux
medium Severity medium
: ---
: 2.4
Assigned To: Marek Polacek
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 04:45 EDT by Miroslav Franc
Modified: 2016-01-31 21:28 EST (History)
4 users (show)

See Also:
Fixed In Version: devtoolset-2-2.1-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-11 02:34:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Franc 2013-10-10 04:45:34 EDT
Description of problem:
When I enable dts (on x86_64 for example) I see that LD_LIBRARY_PATH=/opt/rh/devtoolset-2/root/usr/lib64, but it should be LD_LIBRARY_PATH=/opt/rh/devtoolset-2/root/usr/lib64:/opt/rh/devtoolset-2/root/usr/lib.  In other words 32 lib path should be included as well.


How to reproduce:
1/ Install devtoolset-2-memstomp.i686 on x86_64 distro
2/ LD_PRELOAD="libmemstomp.so" ./something_compiled_with_-m32
ERROR: ld.so: object 'libmemstomp.so' from LD_PRELOAD cannot be preloaded: ignored.
Comment 1 Marek Polacek 2013-10-14 11:56:01 EDT
Fixed in devtoolset-2-2.1-3.el[56]; only lightly tested though.
Comment 6 errata-xmlrpc 2014-03-11 02:34:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0278.html

Note You need to log in before you can comment on or make changes to this bug.