Bug 101762 - unaligned accesses in cannaserver
Summary: unaligned accesses in cannaserver
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: Canna   
(Show other bugs)
Version: 3.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 101028
TreeView+ depends on / blocked
 
Reported: 2003-08-06 15:58 UTC by Micah Parrish
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 00:26:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Micah Parrish 2003-08-06 15:58:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030714
Debian/1.4-2

Description of problem:
When cannaserver is run, errors of this form appear.  

cannaserver(6612): unaligned access to 0x600000000001bc94, ip=0x4000000000026d20
cannaserver(6612): unaligned access to 0x600000000001bc94, ip=0x4000000000026d20
cannaserver(6612): unaligned access to 0x600000000001bc94, ip=0x4000000000027380
cannaserver(6612): unaligned access to 0x600000000001bc94, ip=0x4000000000027380

Seems bad to me.

The hardware this was discovered on is an LP-Madison booted from a SmartArray.



Version-Release number of selected component (if applicable):
Canna-3.6-15

How reproducible:
Always

Steps to Reproduce:
1. run cannaserver

    

Actual Results:  program produced several unaligned access errors as above

Expected Results:  program should run error-free

Additional info:

Comment 1 Akira TAGOH 2003-08-11 10:57:37 UTC
What were you doing this appeared? I just ran the cannaserver with -d option to
debug it on gdb, but I couldn't see any error messages.

Comment 2 Glen A. Foster 2003-08-13 15:10:47 UTC
It happens in the start-up of HP rx2600 (Longs Peak) and rx5670 (Everest)
servers all the time.  All you need is to boot one, but if you're in Japan,
you'll need to get someone in Raleigh to do this for you... and you might need
to get someone to help with debugging it remotely.

Comment 3 Akira TAGOH 2003-10-14 06:55:09 UTC
FYI: I have tracked it down and fixed it locally. it will be available as an errata.

Comment 4 Glen A. Foster 2003-10-14 17:24:27 UTC
Can this please be included in the BASE RELEASE of RHEL3???

Comment 5 Akira TAGOH 2003-10-15 07:18:44 UTC
Unfortunately no, because of the release schedule. I apologize for not fixing
this earlier.

Comment 6 Glen A. Foster 2004-01-26 00:26:52 UTC
This is fixed in RHEL3 update 1

Comment 7 Liudvikas Bukys 2004-05-21 18:52:24 UTC
Did this fix actually make it into IA64 distros?
My Canna RPMs from RHEL 3WS IA64 are -3.6-20,
and neither up2date nor downloaded ISOs of RHEL3 update 2
contain anything different.


Note You need to log in before you can comment on or make changes to this bug.