Bug 1017649 - need to update qmeu-img man help docs page about "VHDX" format disk
need to update qmeu-img man help docs page about "VHDX" format disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
:
Depends On:
Blocks: 1017650 1090305 1090306
  Show dependency treegraph
 
Reported: 2013-10-10 05:39 EDT by Sibiao Luo
Modified: 2014-10-14 02:52 EDT (History)
11 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.431.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1017650 1090305 1090306 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:52:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1490 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2014-10-13 21:28:27 EDT

  None (edit)
Description Sibiao Luo 2013-10-10 05:39:46 EDT
Description of problem:
VHD and VHDX are 2 entirely different formats, but the qemu-img man help document appears to conflate the two. The format 'vpc' is used for VHD, and the format 'vhdx' is used for VHDX. Could you help me update it to make clear of them.

Version-Release number of selected component (if applicable):
host info:
kernel-2.6.32-422.el6.x86_64
qemu-kvm-0.12.1.2-2.412.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.check the qemu-img man help docs that only has VHD info, no VHDX info.
# man qemu-img
...
       vpc VirtualPC compatible image format (VHD).
...
2.the QEMU has support the VHDX format disk indeed.
# /usr/libexec/qemu-kvm -drive format=?
Supported formats: raw cow qcow vdi vmdk cloop dmg bochs vpc vvfat qcow2 qed vhdx parallels nbd blkdebug host_cdrom host_floppy host_device file gluster gluster gluster gluster rbd
3.

Actual results:


Expected results:


Additional info:
Comment 1 Sibiao Luo 2013-10-10 06:06:59 EDT
FYI: from Jeff Cody's comment,
https://bugzilla.redhat.com/show_bug.cgi?id=999779#c5

Just to make sure it is clear:

vpc = vhd = Virtual PC image format

vhdx = Hyper-V image format

vhd != vhdx
vpc != vhdx

"vpc" is really misnamed - the format is really "VHD".  The "VHDX" format, however, is a completely new format not at all similar to "VHD", except that it is also from Microsoft.

So VPC and VHD can be used interchangeably, and is referred to throughout qemu as "vpc". VHDX is completely separate.

Best Regards,
sluo
Comment 4 Miroslav Rezanina 2014-07-23 06:35:05 EDT
Fix included in qemu-kvm-0.12.1.2-2.431.el6
Comment 6 Sibiao Luo 2014-07-28 05:10:43 EDT
Verify this issue on qemu-kvm-rhev-0.12.1.2-2.431.el6.x86_64 version.

host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-493.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.431.el6.x86_64

check the qemu-img man help doc:
...
       vpc VirtualPC compatible image format (VHD).

       vhdx
           Hyper-V compatible image format (VHDX).
...

# /usr/libexec/qemu-kvm -drive format=?
Supported formats: raw cow qcow vdi vmdk cloop dmg bochs vpc vvfat qcow2 qed vhdx parallels nbd blkdebug host_cdrom host_floppy host_device file gluster rbd
^^^^

Best Regards,
sluo
Comment 7 errata-xmlrpc 2014-10-14 02:52:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.