Bug 1017660 - /usr/libexec/qemu-bridge-helper is missing its setuid bit
/usr/libexec/qemu-bridge-helper is missing its setuid bit
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 06:01 EDT by Matthew Booth
Modified: 2013-11-15 15:30 EST (History)
10 users (show)

See Also:
Fixed In Version: qemu-1.4.2-13.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 15:30:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2013-10-10 06:01:01 EDT
Description of problem:
/usr/libexec/qemu-bridge-helper is intended to be installed setuid. It allows non-privileged qemu instances to connect to an existing bridge. It is currently missing its setuid bit:

$ ls -la /usr/libexec/qemu-bridge-helper 
-rwxr-xr-x. 1 root root 15376 Sep 25 07:12 /usr/libexec/qemu-bridge-helper

The spec file does:
chmod u+s $RPM_BUILD_ROOT%{_libexecdir}/qemu-bridge-helper
...
%{_libexecdir}/qemu-bridge-helper

I believe this fails because it is built in a mock chroot. It presumably needs an explit %attr in %files for this to work.

Version-Release number of selected component (if applicable):
qemu-common-1.4.2-11.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Ensure /etc/qemu/bridge.conf contains 'allow virbr0'.
2. Create a libvirt 'session' guest as an unprivileged user.
3. Configure networking with:
    <interface type='bridge'>
      <source bridge='virbr0'/>
    </interface>
4. Start the guest

Actual results:
Permission denied

Expected results:
Guest connected to the virbr0 bridge
Comment 1 Cole Robinson 2013-10-31 17:50:35 EDT
Hmm, this is correct in f18 but not f19+, must need some RPM tweak
Comment 2 Fedora Update System 2013-11-05 20:27:11 EST
qemu-1.4.2-13.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qemu-1.4.2-13.fc19
Comment 3 Fedora Update System 2013-11-06 22:39:32 EST
Package qemu-1.4.2-13.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.4.2-13.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20824/qemu-1.4.2-13.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-11-15 15:30:51 EST
qemu-1.4.2-13.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.