Bug 1017661 - [origin_runtime_243]Failed to specify a port number(2303-2308) or use TLS_PORT_# to support SNI proxy
[origin_runtime_243]Failed to specify a port number(2303-2308) or use TLS_POR...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 06:01 EDT by chunchen
Modified: 2016-09-29 22:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:34:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chunchen 2013-10-10 06:01:29 EDT
Description of problem:
It is failed to specify a port(2304 - 2308) to support SNI proxy in manifest file, and will meet "Unexpected error: Invalid port specified for SNI proxy "/2304" (must either be "", or TLS_PORT_1, TLS_PORT_2, etc...)" errors when creating mock-0.4 app after specifying a port.

If  specifying TLS_PORT1 in the manifest file like following:
      Mappings:
       - Frontend: "TLS_PORT_1"
         Backend: ''
It will still fail with error while creating the app:
Creating application 'mock43' ... Unexpected error: Invalid port specified for SNI proxy "/TLS_PORT_1" (must either be "", or TLS_PORT_1, TLS_PORT_2, etc...): mock43-domx3.dev.rhcloud.com
It seems one more "/" is added to the frontend port.

Version-Release number of selected component (if applicable):
devenv_3881

How reproducible:
always

Steps to Reproduce:
1. SSH into the instance 
2. Modify the manifest file of mock cart as below:
cat /var/lib/openshift/.cartridge_repository/redhat-mock/0.0.1/metadata/manifest.yml
<-----snip------->
    Endpoints:
    - Private-IP-Name: EXAMPLE_IP1
      Private-Port-Name: EXAMPLE_PORT1
      Private-Port: 8123
      Public-Port-Name: EXAMPLE_PUBLIC_PORT1
      Protocols: [tls]
      Mappings:
       - Frontend: "2304"
         Backend: ''
<-----snip------->
OR
<-----snip------->
    Endpoints:
    - Private-IP-Name: EXAMPLE_IP1
      Private-Port-Name: EXAMPLE_PORT1
      Private-Port: 8123
      Public-Port-Name: EXAMPLE_PUBLIC_PORT1
      Protocols: [tls]
      Mappings:
       - Frontend: "TLS_PORT_1"
         Backend: ''
<-----snip------->

3. Create a mock-0.4 app
rhc app create cmk89 mock-0.4


Actual results:
Unexpected error: Invalid port specified for SNI proxy "/2304" (must either be "", or TLS_PORT_1, TLS_PORT_2, etc...): cmk89-ccy.dev.rhcloud.com

Expected results:
Specifying a port to support SNI proxy should be successfully.

Additional info:
It work well for default blank ("")
Comment 1 Xiaoli Tian 2013-10-10 06:31:22 EDT
Adding upcomingrelease keyword since it's a bug for sprint35 but not block sprint34 release
Comment 3 openshift-github-bot 2013-10-10 21:46:50 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/4cf486ead8cb9bfc5ae6b2f329dee67f19c79a7c
Bug 1017661 - Dont add a leading slash in non-http based mappings.  Other fixes.
Comment 4 chunchen 2013-10-11 02:41:45 EDT
It's fixed, verified on devenv_3885.

Note You need to log in before you can comment on or make changes to this bug.