This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1017665 - unexpanded systemd-macros in rpm-scriptlets
unexpanded systemd-macros in rpm-scriptlets
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: awstats (Show other bugs)
20
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 06:03 EDT by Ralf Corsepius
Modified: 2013-11-10 01:19 EST (History)
2 users (show)

See Also:
Fixed In Version: awstats-7.1.1-5.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:19:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2013-10-10 06:03:53 EDT
Description of problem:

awstats for Fedora >= 20 contains broken rpm-scriptlets, which contain unexpanded systemd-macros:

# rpm -q --scripts -p awstats-7.1.1-4.fc20.noarch.rpm 
postinstall scriptlet (using /bin/sh):
if [ $1 -eq 1 ]; then
  if [ ! -f /etc/awstats/awstats.`hostname`.conf ]; then
    /usr/bin/cat /etc/awstats/awstats.model.conf | \
      /usr/bin/perl -p -e 's|^SiteDomain=.*$|SiteDomain="'`hostname`'"|;
                       s|^HostAliases=.*$|HostAliases="REGEX[^.*'${HOSTNAME//./\\\\.}'\$]"|;
                      ' > /etc/awstats/awstats.`hostname`.conf || :
  fi
fi
postuninstall scriptlet (using /bin/sh):
%systemd_postun_with_restart httpd.service

Additional info:
- The cause of this issue is the spec missing a BR: systemd to pull-in the necessary systemd.macros.
- These unexpanded systemd macros cause yum update failures, leaving behind duplicate entries in rpmdb.
Comment 1 Fedora Update System 2013-10-10 06:18:31 EDT
awstats-7.1.1-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/awstats-7.1.1-5.fc20
Comment 2 Fedora Update System 2013-10-11 12:47:24 EDT
Package awstats-7.1.1-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing awstats-7.1.1-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18842/awstats-7.1.1-5.fc20
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-11-10 01:19:04 EST
awstats-7.1.1-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.