Bug 101770 - rhnpush fails with kerberized account
rhnpush fails with kerberized account
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Red Hat Satellite QA List
:
Depends On:
Blocks: 99546
  Show dependency treegraph
 
Reported: 2003-08-06 12:57 EDT by Jason Verch
Modified: 2007-07-31 15:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:47:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Verch 2003-08-06 12:57:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; CPT-IE401SP1; 
Q312461; .NET CLR 1.1.4322)

Description of problem:
We are using PAM authentication for kerberized RHN accounts. Everything works 
fine through the gui but rhnpush fails on the command line. I had to create 
myself a non PAM authenticated account as a workaround to use rhnpush.


Version-Release number of selected component (if applicable):
rhnpush-2.5.1-11

How reproducible:
Always

Steps to Reproduce:
1. rhnpush
2. use kerberized (through PAM) account
3.
    

Actual Results:  Error Class Code: 2
Error Class Info: Invalid username and password combination.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Expected Results:  upload new RPM to channel.

Additional info:

using an account with a RHN password instead of PAM authentication works as 
expected.
Comment 1 Mihai Ibanescu 2003-08-06 14:55:39 EDT
Code fixed.
Comment 4 Josef Komenda 2003-08-06 18:15:17 EDT
Looks good in the 2.0.1-10 satellite.
Comment 5 Greg DeKoenigsberg 2003-08-15 23:25:04 EDT
Since we actually got this into the rhn260sat release, and since it's already 
aligning underneath rhn260, I'm pulling it from rhn270.

Note You need to log in before you can comment on or make changes to this bug.