Bug 1017701 - javapackages-tools: Incorrect versioned requires
javapackages-tools: Incorrect versioned requires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Upstream, VerifiedUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 07:07 EDT by Mikolaj Izdebski
Modified: 2013-11-07 02:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.4.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 02:11:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-10-10 07:07:42 EDT
Description of problem:
In some cases generated requires are versioned when they should be versionless.

Version-Release number of selected component (if applicable):
3.3.1-1

Steps to Reproduce:
Run autorequires generator for package with the following two fragments:

$ cat api.xml 
<?xml version="1.0" encoding="US-ASCII"?>
<!-- This depmap file was generated by XMvn -->
<dependencyMap>
  <dependency>
    <maven>
      <namespace>maven31</namespace>
      <groupId>org.eclipse.aether</groupId>
      <artifactId>aether-api</artifactId>
      <version>0.9.0.M3</version>
    </maven>
    <jpp>
      <namespace>maven31</namespace>
      <groupId>JPP/maven31-aether</groupId>
      <artifactId>aether-api</artifactId>
    </jpp>
  </dependency>
</dependencyMap>

$ cat spi.xml 
<?xml version="1.0" encoding="US-ASCII"?>
<!-- This depmap file was generated by XMvn -->
<dependencyMap>
  <dependency>
    <maven>
      <namespace>maven31</namespace>
      <groupId>org.eclipse.aether</groupId>
      <artifactId>aether-spi</artifactId>
      <version>0.9.0.M3</version>
    </maven>
    <jpp>
      <namespace>maven31</namespace>
      <groupId>JPP/maven31-aether</groupId>
      <artifactId>aether-spi</artifactId>
    </jpp>
  </dependency>
  <autoRequires>
    <groupId>org.eclipse.aether</groupId>
    <artifactId>aether-api</artifactId>
  </autoRequires>
</dependencyMap>

Actual results:
Generated Requires is:
mvn(org.eclipse.aether:aether-api) = 0.9.0.M3

Expected results:
Generated Requires should be:
mvn(org.eclipse.aether:aether-api)
Comment 1 Stanislav Ochotnicky 2013-10-11 06:29:57 EDT
Fix upstream in b03c361c937, test case in 782d6394 (fixed in 78f4748b)
Comment 2 Mikolaj Izdebski 2013-10-14 14:58:28 EDT
Versioned requires are still not working as expected.

Version-Release number of selected component (if applicable):
3.4.0-2

New reproducer:

require.xml:
<dependencyMap>
  <dependency>
    <maven>
      <namespace>maven31</namespace>
      <groupId>org.eclipse.aether</groupId>
      <artifactId>aether-spi</artifactId>
      <version>0.9.0.M3</version>
    </maven>
    <jpp>
      <namespace>maven31</namespace>
      <groupId>JPP/maven31-aether</groupId>
      <artifactId>aether-spi</artifactId>
    </jpp>
  </dependency>
  <autoRequires>
    <namespace>maven31</namespace>
    <groupId>org.eclipse.aether</groupId>
    <artifactId>aether-api</artifactId>
  </autoRequires>
</dependencyMap>

fragment.xml:
<dependencyMap>
  <dependency>
    <maven>
      <namespace>maven31</namespace>
      <groupId>org.eclipse.aether</groupId>
      <artifactId>aether-api</artifactId>
      <version>0.9.0.M3</version>
    </maven>
    <jpp>
      <namespace>maven31</namespace>
      <groupId>JPP/maven31-aether</groupId>
      <artifactId>aether-api</artifactId>
    </jpp>
  </dependency>
</dependencyMap>

Expected require generated:
maven31-mvn(org.eclipse.aether:aether-api) = 0.9.0.M3

Actual require generated:
maven31-mvn(org.eclipse.aether:aether-api)
Comment 3 Mikolaj Izdebski 2013-10-15 02:52:20 EDT
Reproducer added as a unit test case in 05c839bc
Comment 4 Stanislav Ochotnicky 2013-10-15 07:04:26 EDT
Fixed upstream in 0fd12961
Comment 5 Mikolaj Izdebski 2013-11-07 02:08:32 EST
Fixed in javapackages-tools-3.4.1-1
Comment 6 Mikolaj Izdebski 2013-11-07 02:11:17 EST
I believe that this bug is fixed in javapackages-tools-3.4.1-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=476325

Note You need to log in before you can comment on or make changes to this bug.