Bug 1017702 - javapackages-tools: Incorrect requires on package providing filesystem
javapackages-tools: Incorrect requires on package providing filesystem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
rawhide
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Michal Srb
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 07:12 EDT by Mikolaj Izdebski
Modified: 2015-02-05 01:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-05 01:42:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-10-10 07:12:11 EDT
Description of problem:
Packages with non-empty <namespace> have auto-requires on jpackage-utils instead on <namespace>-runtime.

Version-Release number of selected component (if applicable):
3.3.1-1

Steps to Reproduce:
Run autorequires generator for package with the following fragment:

$ cat depmap.xml 
<?xml version="1.0" encoding="US-ASCII"?>
<!-- This depmap file was generated by XMvn -->
<dependencyMap>
  <dependency>
    <maven>
      <namespace>maven31</namespace>
      <groupId>org.eclipse.aether</groupId>
      <artifactId>aether-api</artifactId>
      <version>0.9.0.M3</version>
    </maven>
    <jpp>
      <namespace>maven31</namespace>
      <groupId>JPP/maven31-aether</groupId>
      <artifactId>aether-api</artifactId>
    </jpp>
  </dependency>
</dependencyMap>

Actual results:
Generated Requires is:
jpackage-utils

Expected results:
Generated Requires should be:
maven31-runtime
Comment 1 Stanislav Ochotnicky 2013-10-10 08:44:39 EDT
Testcases in a0de7eab, fix in a72ad0519
Comment 2 Mikolaj Izdebski 2013-10-10 10:33:33 EDT
This is still not correct.

1) javadoc packages in SCL do not have any requires, but they should require <namespace>-runtime

2) if package provides artifacts with namespace and without namespace only <namespace>-runtime is generated, but both jpackage-utils and <namespace>-runtime should be generated

3) if package provides artifacts in nore then one non-empty namespace then only one of them will be used to generate requires, but all namespaced should be used to produce <namespace>-runtime require
Comment 3 Stanislav Ochotnicky 2013-10-11 10:53:24 EDT
More tests added in 6dcfa86 and fixed in 9ec6128. The javadoc packages are still not fixed though so leaving in assigned
Comment 4 Fedora Admin XMLRPC Client 2014-04-24 08:47:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Mikolaj Izdebski 2014-12-14 16:19:50 EST
It is important to have this fixed in 4.3.x.
Comment 6 Michal Srb 2015-02-05 01:42:21 EST
I believe that this bug is properly fixed in javapackages-tools 4.3.2, which is available in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.