Bug 1017714 - packstack [Swift]: cannot install swift using packstack
packstack [Swift]: cannot install swift using packstack
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
x86_64 Linux
unspecified Severity high
: ---
: 4.0
Assigned To: RHOS Maint
Nir Magnezi
storage
: Regression, TestBlocker
Depends On:
Blocks: 1012407
  Show dependency treegraph
 
Reported: 2013-10-10 07:27 EDT by Dafna Ron
Modified: 2013-10-17 07:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 07:00:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (3.76 KB, application/x-xz)
2013-10-10 07:27 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1237927 None None None Never

  None (edit)
Description Dafna Ron 2013-10-10 07:27:37 EDT
Created attachment 810462 [details]
log

Description of problem:

I tried for 3 days to install swift from packstack and consistently failing to install openstack with swift. 

If I use external data server the installation will hang forever so to debug it I gave the data servers the local machine ip and the error we are getting is a package key error for  /usr/bin/yum -d 0 -e 0 -y install openstack-swift

but... packages are already installed by packstack ... so if I run this manually we get the following: 

[root@nott-vdsa ~]# /usr/bin/yum -d 0 -e 0 -y install openstack-swift
Package openstack-swift-1.9.1-2.el6ost.noarch already installed and latest version


Version-Release number of selected component (if applicable):

ackage openstack-swift-1.9.1-2.el6ost.noarch already installed and latest version
[root@nott-vdsa ~]# rpm -qa |grep packstack 
openstack-packstack-2013.2.1-0.6.dev763.el6ost.noarch
[root@nott-vdsa ~]# rpm -qa |grep swift 
python-swiftclient-1.6.0-1.el6ost.noarch
openstack-swift-proxy-1.9.1-2.el6ost.noarch
openstack-swift-plugin-swift3-1.0.0-0.20120711git.1.el6ost.noarch
openstack-swift-1.9.1-2.el6ost.noarch
[root@nott-vdsa ~]# 

rhel6.5 with puddle 2013-10-03.3 

How reproducible:

100%

Steps to Reproduce:
1. install a clean machine with rhel6.5 
2. try to install openstack with swift using packstack 
3.

Actual results:

we fail installation because of swift packages 

Expected results:

we should be able to install swift with packstack 

Additional info:
Comment 1 Martin Magr 2013-10-17 07:00:33 EDT
From the attached log file I see that it's a repo setup problem:
[1;31mError: Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-swift' returned 1: warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY


GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
[0m
[1;31mError: /Stage[main]/Swift/Package[swift]/ensure: change from absent to latest failed: Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-swift' returned 1: warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY


GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6


This is not a Packstack issue.

Note You need to log in before you can comment on or make changes to this bug.