Bug 1017732 - Split of kde and gnome frontends to subpackages
Split of kde and gnome frontends to subpackages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: debconf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Oron Peled
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 08:04 EDT by Sandro Mani
Modified: 2014-01-29 22:38 EST (History)
3 users (show)

See Also:
Fixed In Version: debconf-1.5.52-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:22:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff (3.07 KB, patch)
2013-10-11 10:58 EDT, Sandro Mani
no flags Details | Diff
Diff (3.42 KB, patch)
2013-10-11 11:00 EDT, Sandro Mani
no flags Details | Diff

  None (edit)
Description Sandro Mani 2013-10-10 08:04:33 EDT
Description of problem:
I'd like to suggest to split off the kde and gnome fontends of debconf to respective -kde and -gnome subpackages. This saves ca 233 MB of dependencies on servers which do not run a desktop environment. This change is safe, since the frontend to use is determined dynamically in AutoSelect.pm based on the installed frontends.

I've implemented this in the following SRPM: http://smani.fedorapeople.org/debconf-1.5.51-1.fc21.src.rpm

Version-Release number of selected component (if applicable):
debconf-1.5.49-5.fc21
Comment 1 Sandro Mani 2013-10-11 10:33:28 EDT
By the way: since I maintain a number of other debian related packages, I'm happy to comaintain this one too if desired.
Comment 2 Sergio Monteiro Basto 2013-10-11 10:55:59 EDT
Sandro , have you a diff of the spec ? can you attach it ? this weekend I'll review all debs things.
Comment 3 Sandro Mani 2013-10-11 10:58:29 EDT
Created attachment 811191 [details]
Diff

Sure, here you go. Thanks!
Comment 4 Sandro Mani 2013-10-11 11:00:30 EDT
Created attachment 811192 [details]
Diff
Comment 5 Fedora Update System 2013-10-17 20:36:11 EDT
debconf-1.5.51-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/debconf-1.5.51-1.fc20
Comment 6 Fedora Update System 2013-10-17 20:51:24 EDT
debconf-1.5.51-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/debconf-1.5.51-1.fc19
Comment 7 Fedora Update System 2013-10-18 20:13:33 EDT
Package debconf-1.5.51-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing debconf-1.5.51-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19417/debconf-1.5.51-1.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-11-10 02:22:46 EST
debconf-1.5.51-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-01-06 18:32:57 EST
debconf-1.5.52-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/debconf-1.5.52-1.fc19
Comment 10 Sergio Monteiro Basto 2014-01-06 18:42:51 EST
(In reply to Fedora Update System from comment #9)
> debconf-1.5.52-1.fc19 has been submitted as an update for Fedora 19.
> https://admin.fedoraproject.org/updates/debconf-1.5.52-1.fc19

Update successfully created. This update has obsoleted debconf-1.5.51-1.fc19, and has inherited its bugs and notes.

That's why we are getting this notification ...
Comment 11 Fedora Update System 2014-01-29 22:38:28 EST
debconf-1.5.52-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.