Bug 1017733 - Checking ejb-multi-server example functionality fails. URL http://localhost:8380/appweb/ is unavailable
Checking ejb-multi-server example functionality fails. URL http://localhost:8...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER7
: EAP 6.2.0
Assigned To: sgilda
Vladimir Rastseluev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 08:06 EDT by Vladimir Rastseluev
Modified: 2017-10-09 20:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:19:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Rastseluev 2013-10-10 08:06:28 EDT
Description of problem:
I checked functionality of ejb-multi-server quickstart example and tried to go to URL http://localhost:8380/appweb/. It is unavailable : responce code is 404
- JBWEB000069: description JBWEB000124: The requested resource is not available.

After server reload I can see in log also:
11:54:03,900 INFO  [org.jboss.as.process.Server:app-web.status] (reaper for Server:app-web) JBAS012010: Process 'Server:app-web' finished with an exit status of 1
[Host Controller] 11:54:03,906 INFO  [org.jboss.as.host.controller] (ProcessControllerConnection-thread - 2) JBAS010926: Unregistering server app-web


Version-Release number of selected component (if applicable):
EAP 6.2.0 ER5.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 sgilda 2013-10-10 13:10:30 EDT
Did you see the Note in that section?

NOTE : A new feature in EAP 6.1 or later will deny the invocation of unsecured methods of appOne/appTwo since security is enabled but the method does not include @Roles. You need to set ‘default-missing-method-permissions-deny-access = false’ for the ejb3 subsystem within the domain profile “ha” and “default” to allow the method invocation. See the install-domain.cli script.


Did you follow those instructions?

I am tempted to remove that entire section. I'm not sure it shows anything since it does not work by default anad you have to jump through hoops for it to work.
Comment 2 Vladimir Rastseluev 2013-10-11 03:19:40 EDT
I didn't follow that, but as I can see, these changes were made in domain.xml configuration, so it should work.
It's better to remove this entire section, if it doesn't work.
Comment 3 sgilda 2013-10-11 09:42:09 EDT
Adding Wolf so he can comment.
Comment 4 sgilda 2013-10-11 15:44:55 EDT
I finally got a chance to test this and it doesn't work for me either. I sent an email to Wolf to ask if he wants to debug this or if we should just remove the section.
Comment 5 wfink 2013-10-17 13:38:04 EDT
As the deployment names are changed a WEB-INF/jboss-web.xml is necesarry to set the correct context-root.

PR send https://github.com/jboss-developer/jboss-eap-quickstarts/pull/685
Comment 6 sgilda 2013-10-17 15:18:20 EDT
I closed the above pull because we don't want to hard-code the context-root. We wnat to use the name generated by the build using the variable: ${project.artifactId}

I did the following:
* Removed the hard-code context root from app-main/ear/pom.xml
* Udated the access URLs in the README to use the generated contexts
* Moved the section on adding users. It was in the middle of the section on configuring the server and it was confusing. I moved that section prior to the server configuration. 

Fixes are in this pull:
https://github.com/jboss-developer/jboss-eap-quickstarts/pull/686
Comment 8 Vladimir Rastseluev 2013-11-01 09:10:16 EDT
Verified on EAP 6.2 ER7

Note You need to log in before you can comment on or make changes to this bug.