Bug 1017744 - [webadmin] Logging in to webadmin without explicit https does not redirect
[webadmin] Logging in to webadmin without explicit https does not redirect
Status: CLOSED DUPLICATE of bug 1018111
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: nobody nobody
Pavel Stehlik
Depends On:
  Show dependency treegraph
Reported: 2013-10-10 08:29 EDT by Gadi Ickowicz
Modified: 2014-08-21 21:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-10-11 09:59:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
server log (379.48 KB, application/gzip)
2013-10-10 08:29 EDT, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2013-10-10 08:29:01 EDT
Created attachment 810500 [details]
server log

Description of problem:
After installing rhevm, attempting to log in to the web portal without explicitly specifying https:// as part of the URL fails. This used to work in previous versions, just typing in the FQDN or IP of the engine without protocl and it would redirect to https. It no longer does that.

The server logs show the following error:
2013-10-10 15:22:53,996 DEBUG [org.apache.coyote.ajp.AjpMessage] (ajp-/ Received 876 18
2013-10-10 15:22:53,996 DEBUG [org.apache.coyote.http11] (ajp-/ JBWEB003036: Invalid cookie header [rh_omni_tc=70160000000H4AoAAK; rh_elqCustomerGUID=3fac451a-78b6-4274-8c3e-55b03a3db6bf; __utma=1
85718442.1592129403.1375602588.1375602588.1378885546.2; __utmz=185718442.1375602588.1.1.utmcsr=docspace.corp.redhat.com|utmccn=(referral)|utmcmd=referral|utmcct=/docs/DOC-144552; s_fid=328E3337B9F70DB5-0B14A3AC013
2CC30; s_vi=[CS]v1|2892644D051D2EB9-600001354027ADA8[CE]; locale=en_US].

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Type in the fqdn or ip of the engine in the address bar of the browser *without* specifying protocl (http:// or https://
2. Click on the link for administrator portal

Actual results:
Error page appears with the following error:
JBWEB000065: HTTP Status 403 -

JBWEB000309: type JBWEB000067: Status report

JBWEB000068: message

JBWEB000069: description JBWEB000123: Access to the specified resource has been forbidden.

JBoss Web/7.2.2.Final-redhat-1

Expected results:
Should redirect to https

Additional info:
Comment 1 Itamar Heim 2013-10-11 09:59:52 EDT

*** This bug has been marked as a duplicate of bug 1018111 ***

Note You need to log in before you can comment on or make changes to this bug.