Bug 1017745 - Use community bom
Use community bom
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER5
: ---
Assigned To: Horia Chiorean
: QA-Closed
Depends On: 1006607
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 08:32 EDT by Nick Cross
Modified: 2016-02-10 03:55 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:55:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Cross 2013-10-10 08:32:16 EDT
Modeshape should import and align to use the versions in the community integration platform bom (https://github.com/jboss-integration/jboss-integration-platform-bom/)
Comment 2 Horia Chiorean 2013-10-14 06:56:31 EDT
From a ModeShape perspective, the following changes are required (blocker) before being able to actually use the BOM:

1) Remove dependency exclusions, with the exception of the cases where those exclusions actually fix a bug in the owning artifact (i.e. wrong transitive dependency set).  See https://bugzilla.redhat.com/show_bug.cgi?id=1006607.

2) Change the Infinispan & JGroups versions to match those from EAP 6.1.1 - 5.2.7.Final and 3.2.10.Final.

Also, the Lucene 4.0.0 dependency is in conflict with what ModeShape requires: 3.6.2.Final. ModeShape requires this version from 2 different places:

a) directly - it uses the Lucene API
b) via Hibernate Search 4.3.0.Final

Since 4.0.0 is a major Lucene version change, the only option atm. is for ModeShape to overwrite this dependency.
Comment 3 Horia Chiorean 2013-10-23 11:10:30 EDT
In order to DEV ACK this, the following have to be resolved:

1) the Lucene version conflict - ModeShape *cannot* move to 4.0.0 (see mailing list for the discussion)
2) https://bugzilla.redhat.com/show_bug.cgi?id=1006607 needs to be fixed
Comment 4 Horia Chiorean 2013-10-24 08:55:07 EDT
Removed DEV ACK (see previous comment)
Comment 5 Horia Chiorean 2013-10-24 10:55:42 EDT
To re-describe the problem:

1) the current BOM version has by default transitive dependencies exclusions (e.g. in the case of infinispan-core) which negatively affect any project which uses that BOM. This is an acknowledged issue which is "documented" in: https://bugzilla.redhat.com/show_bug.cgi?id=1006607

2) DroolsJBPM apparently needs Lucene 4.0 (which is what the current BOM version has), while ModeShape cannot work with this version because a) it's a major API change/incompatibility and b) isn't used by the version of Hibernate Search that ModeShape requires. One way to solve this conflict is to acknowledge that one of the 2 projects needs to overwrite this version.
Comment 6 Horia Chiorean 2013-10-24 12:28:49 EDT
Until the above described issues are not solved and/or decided upon, ModeShape cannot change to use the integration BOM.

It's also worth mentioning that the component versions ModeShape uses are aligned with EAP 6.1.1, so there shouldn't be any version conflicts when building the products.
Comment 7 Horia Chiorean 2013-10-28 08:24:08 EDT
From a DV perspective, has Teiid made these changes in their product branch ?
Comment 9 Horia Chiorean 2013-11-06 12:15:32 EST
ModeShape's build system in the product repository now uses the integration bom.

The last commit id: https://github.com/jboss-integration/modeshape/commit/dbabef399d415336417bf0a1f26145680ff77c70
Comment 10 Horia Chiorean 2013-11-13 08:56:31 EST
Changed back to ASSIGNED, because of the latest changes regarding splitting the BOM. Additional work is required once the IP BOM changes have occurred.
Comment 11 Horia Chiorean 2013-11-13 15:00:07 EST
Updated ModeShape to use the split version of the BOM.
Commit ID: https://github.com/jboss-integration/modeshape/commit/f1bfac05f27b80618ed4799ecc94176632539b18
Comment 12 belong 2013-12-01 23:10:20 EST
Assuming this is not to be reported as an issue in the Release Notes - setting to requires_doc_text- accordingly.

Note You need to log in before you can comment on or make changes to this bug.