Bug 1017760 - with lvm_type=thin parsing of lvm version fails and openstack-cinder-volume won't start
with lvm_type=thin parsing of lvm version fails and openstack-cinder-volume w...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity high
: beta
: 4.0
Assigned To: Giulio Fidente
Haim
storage
: TestBlocker
Depends On:
Blocks: 975606
  Show dependency treegraph
 
Reported: 2013-10-10 09:06 EDT by Giulio Fidente
Modified: 2016-04-26 21:16 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.12.rc2.el6ost
Doc Type: Bug Fix
Doc Text:
Cause: LVM versioning was not expected to contain strings while these could be used in custom builds of the LVM tools. Consequence: LVM version parsing, needed to ensure availability of Thin provisioning, was failing to initialize, causing openstack-cinder-volume service to not start. Fix: The parser now uses a regexp to inspect only the relevant digits. Result: LVM version is parsed correctly and openstack-cinder-volume starts as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:27:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1237994 None None None Never
OpenStack gerrit 50919 None None None Never

  None (edit)
Description Giulio Fidente 2013-10-10 09:06:34 EDT
Description of problem:
openstack-cinder-volume does not start when using lvm_type=thin and the following appears in the logs:

2013-10-10 14:58:56.928 32460 TRACE cinder.service File "/usr/lib/python2.6/site-packages/cinder/brick/local_dev/lvm.py", line 142, in supports_thin_provisioning
2013-10-10 14:58:56.928 32460 TRACE cinder.service version_tuple = tuple(map(int, version.split('.')))
2013-10-10 14:58:56.928 32460 TRACE cinder.service ValueError: invalid literal for int() with base 10: '100-RHEL6'
Version-Release number of selected component (if applicable):


Steps to Reproduce:
1. enable thinlvm by setting lvm_type=thin in cinder.conf
2. restart openstack-cinder-volume
Comment 1 Giulio Fidente 2013-10-10 09:08:57 EDT
Version-Release number of selected component (if applicable):
openstack-cinder-2013.2-0.9.b3.el6ost.noarch
Comment 3 Scott Lewis 2013-11-18 15:35:35 EST
Adding to beta milestone for MODIFIED/ON-QA bugs
Comment 4 Haim 2013-11-19 06:28:57 EST
moving to verified on openstack-cinder-2013.2-2.el6ost.noarch.

there are different issues with thin lvm but service is running.
Comment 7 errata-xmlrpc 2013-12-19 19:27:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.