Bug 1017764 - Build of dtgov-demos fails
Build of dtgov-demos fails
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance, Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER5
: 6.0.0
Assigned To: Nick Cross
Jiri Sedlacek
:
Depends On:
Blocks: 1019379
  Show dependency treegraph
 
Reported: 2013-10-10 09:17 EDT by Stefan Bunciak
Modified: 2015-08-02 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1019379 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Bunciak 2013-10-10 09:17:10 EDT
Description of problem:

[sbunciak@sbunciak-ntb dtgov]$ mvn clean verify
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO] 
[INFO] DTGov Demos
[INFO] DTGov Demos Project: Project Lifecycle Management
[INFO] DTGov Demos Project: Project
[INFO] DTGov Demos: Project - Service API
[INFO] DTGov Demos: Switchyard Deployment
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building DTGov Demos 1.0.1.Final-redhat-4
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- maven-clean-plugin:2.4.1-redhat-1:clean (default-clean) @ dtgov-demos ---
[INFO] 
[INFO] --- maven-enforcer-plugin:1.0-redhat-1:enforce (enforce-java-version) @ dtgov-demos ---
[INFO] 
[INFO] --- maven-enforcer-plugin:1.0-redhat-1:enforce (enforce-maven-version) @ dtgov-demos ---
[INFO] 
[INFO] --- buildnumber-maven-plugin:1.0-redhat-1:create-timestamp (get-build-timestamp) @ dtgov-demos ---
[INFO] 
[INFO] --- buildnumber-maven-plugin:1.0-redhat-1:create (get-scm-revision) @ dtgov-demos ---
[INFO] Checking for local modifications: skipped.
[INFO] Updating project files from SCM: skipped.
[INFO] Executing: /bin/sh -c cd /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov && git show
[INFO] Working directory: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov
[WARNING] Cannot get the revision information from the scm repository, proceeding with revision of UNKNOWN : 
Exception while executing SCM command.
[INFO] Storing buildNumber: UNKNOWN at timestamp: 1381410517780
[INFO] Executing: /bin/sh -c cd /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov && git show
[INFO] Working directory: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov
[WARNING] Cannot get the branch information from the scm repository, proceeding with UNKNOWN_BRANCH : 
Exception while executing SCM command.
[INFO] Storing buildScmBranch: UNKNOWN_BRANCH
[INFO] 
[INFO] --- maven-source-plugin:2.1.2-redhat-1:jar-no-fork (attach-sources) @ dtgov-demos ---
[INFO] 
[INFO] --- maven-assembly-plugin:2.2.1-redhat-1:single (make-dist) @ dtgov-demos ---
[INFO] Reading assembly descriptor: src/main/assembly/dist.xml
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] DTGov Demos ....................................... FAILURE [0.779s]
[INFO] DTGov Demos Project: Project Lifecycle Management . SKIPPED
[INFO] DTGov Demos Project: Project ...................... SKIPPED
[INFO] DTGov Demos: Project - Service API ................ SKIPPED
[INFO] DTGov Demos: Switchyard Deployment ................ SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.817s
[INFO] Finished at: Thu Oct 10 15:08:38 CEST 2013
[INFO] Final Memory: 9M/152M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.2.1-redhat-1:single (make-dist) on project dtgov-demos: Error reading assemblies: Error locating assembly descriptor: src/main/assembly/dist.xml
[ERROR] 
[ERROR] [1] [INFO] Searching for file location: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov/src/main/assembly/dist.xml
[ERROR] 
[ERROR] [2] [INFO] File: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov/src/main/assembly/dist.xml does not exist.
[ERROR] 
[ERROR] [3] [INFO] File: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov/src/main/assembly/dist.xml does not exist.
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Gary Brown 2013-10-10 09:24:46 EDT
This looks like a prod issue? Is it related to the structuring of the quickstart folder?
Comment 2 Kurt T Stam 2013-10-10 09:39:32 EDT
Can you run using the -Pdemo profile?
Comment 3 Stefan Bunciak 2013-10-10 09:43:19 EDT
[sbunciak@sbunciak-ntb dtgov]$ mvn clean verify -Pdemo
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO] 
[INFO] DTGov Demos
[INFO] DTGov Demos Project: Project Lifecycle Management
[INFO] DTGov Demos Project: Project
[INFO] DTGov Demos: Project - Service API
[INFO] DTGov Demos: Switchyard Deployment
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building DTGov Demos 1.0.1.Final-redhat-4
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- maven-clean-plugin:2.4.1-redhat-1:clean (default-clean) @ dtgov-demos ---
[INFO] 
[INFO] --- maven-enforcer-plugin:1.0-redhat-1:enforce (enforce-java-version) @ dtgov-demos ---
[INFO] 
[INFO] --- maven-enforcer-plugin:1.0-redhat-1:enforce (enforce-maven-version) @ dtgov-demos ---
[INFO] 
[INFO] --- buildnumber-maven-plugin:1.0-redhat-1:create-timestamp (get-build-timestamp) @ dtgov-demos ---
[INFO] 
[INFO] --- buildnumber-maven-plugin:1.0-redhat-1:create (get-scm-revision) @ dtgov-demos ---
[INFO] Checking for local modifications: skipped.
[INFO] Updating project files from SCM: skipped.
[INFO] Executing: /bin/sh -c cd /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov && git show
[INFO] Working directory: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov
[WARNING] Cannot get the revision information from the scm repository, proceeding with revision of UNKNOWN : 
Exception while executing SCM command.
[INFO] Storing buildNumber: UNKNOWN at timestamp: 1381412504871
[INFO] Executing: /bin/sh -c cd /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov && git show
[INFO] Working directory: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov
[WARNING] Cannot get the branch information from the scm repository, proceeding with UNKNOWN_BRANCH : 
Exception while executing SCM command.
[INFO] Storing buildScmBranch: UNKNOWN_BRANCH
[INFO] 
[INFO] --- maven-source-plugin:2.1.2-redhat-1:jar-no-fork (attach-sources) @ dtgov-demos ---
[INFO] 
[INFO] --- maven-assembly-plugin:2.2.1-redhat-1:single (make-dist) @ dtgov-demos ---
[INFO] Reading assembly descriptor: src/main/assembly/dist.xml
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] DTGov Demos ....................................... FAILURE [0.692s]
[INFO] DTGov Demos Project: Project Lifecycle Management . SKIPPED
[INFO] DTGov Demos Project: Project ...................... SKIPPED
[INFO] DTGov Demos: Project - Service API ................ SKIPPED
[INFO] DTGov Demos: Switchyard Deployment ................ SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3.223s
[INFO] Finished at: Thu Oct 10 15:41:45 CEST 2013
[INFO] Final Memory: 24M/286M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.2.1-redhat-1:single (make-dist) on project dtgov-demos: Error reading assemblies: Error locating assembly descriptor: src/main/assembly/dist.xml
[ERROR] 
[ERROR] [1] [INFO] Searching for file location: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov/src/main/assembly/dist.xml
[ERROR] 
[ERROR] [2] [INFO] File: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov/src/main/assembly/dist.xml does not exist.
[ERROR] 
[ERROR] [3] [INFO] File: /home/sbunciak/runtimes/fsw-6.0.0.ER4/jboss-eap-6.1/quickstarts/overlord/dtgov/src/main/assembly/dist.xml does not exist.
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
Comment 5 Kurt T Stam 2013-10-11 10:01:29 EDT
This does not happen in the DTGov distro. I will compare the project and product poms to see what's going on.
Comment 6 Kurt T Stam 2013-10-11 12:00:06 EDT
Something in the prod process adds 

<parent>
    <artifactId>ip-parent</artifactId>
    <groupId>org.jboss.ip.component.management</groupId>
    <version>1.0-redhat-6</version>
  </parent>

as well as adding some management dependencies. 

In the project we specifically don't have a parent so it is a standalone pom.

It is not supposed to be creating an assembly as part of the demo phase. If the prod changes keep being incompatible, then maybe the vman script can remove the assembly config from  the dtgov-demos/pom.xml?
Comment 7 Julian Coleman 2013-10-15 11:24:10 EDT
The problem is that the dtgov-demos zip packages up the top-level pom.xml file.
If you try and use this POM file to build, it will reference the non-existent
assembly.

The workaround is to remove this top-level pom.xml from the platform assembly
for ER5.

The fix is probably to exclude pom.xml from the dtgov-demos assembly (see: https://bugzilla.redhat.com/show_bug.cgi?id=1019379)
Comment 8 Nick Cross 2013-10-16 06:00:23 EDT
Fixed by 7c71ebc1dc88af1bb2528935a38789da5ea68498 in branch
Comment 9 kconner 2013-10-16 19:32:59 EDT
The online repository at http://maven.repository.redhat.com/techpreview/ip6/6.0.0.Beta/maven-repository does not contain the removed pom.xml so it is no longer possible to build this quickstart within the current ER5 spin.

We can either fix this by adding the pom.xml into the repository or by reinstating the pom.xml and removing the assembly code.  I am currently favouring the second at present as we have no need to create an assembly in the platform.

rincewind:~ kevin$ diff FSW-ER4/jboss-eap-6.1/quickstarts/dtgov-demos/pom.xml FSW-ER5/jboss-eap-6.1/quickstarts/overlord/dtgov/pom.xml 
120,144d119
<       <plugin>
<         <artifactId>maven-assembly-plugin</artifactId>
<         <inherited>false</inherited>
<         <executions>
<           <execution>
<             <id>make-dist</id>
<             <phase>package</phase>
<             <goals>
<               <goal>single</goal>
<             </goals>
<             <configuration>
<               <escapeString>\</escapeString>
<               <attach>true</attach>
<               <descriptors>
<                 <descriptor>src/main/assembly/dist.xml</descriptor>
<               </descriptors>
<               <tarLongFileMode>gnu</tarLongFileMode>
<               <appendAssemblyId>false</appendAssemblyId>
<               <archiverConfig>
<                 <defaultDirectoryMode>0755</defaultDirectoryMode>
<               </archiverConfig>
<             </configuration>
<           </execution>
<         </executions>
<       </plugin>

We can tidy up the dtgov-demos after beta.
Comment 10 Nick Cross 2013-10-17 08:14:42 EDT
Try two - should be fixed by 8d2c2f4eb709b532248a337a72363b82ae71b79a
Comment 11 Jiri Sedlacek 2013-10-18 08:55:01 EDT
verified in ER6

Note You need to log in before you can comment on or make changes to this bug.