Bug 1017812 - Wrong explanation in chapter "Application Resources"
Wrong explanation in chapter "Application Resources"
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: post-GA
: EAP 6.4.1
Assigned To: Zach Rhoads
Ladislav Thon
: Documentation
Depends On:
Blocks: 1013506
  Show dependency treegraph
 
Reported: 2013-10-10 10:39 EDT by Ladislav Thon
Modified: 2015-10-20 08:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14874, Administration and Configuration Guide-6.2-1 Build Date: 10-10-2013 14:56:59 Topic ID: 23146-541286 [Latest]
Last Closed: 2015-10-20 08:51:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladislav Thon 2013-10-10 10:39:40 EDT
Title: Application Resources

Describe the issue:

The text says that "by default no resource types are enabled as application resources", which is not true. Deployments are by default enabled as application resources. The issue here is that the text is not considering deployments to be resources, which I believe is wrong. For example, you can revoke the permissions to deployments from Deployer in the same way you can grant permissions to other resources.

Suggestions for improvement:

I suggest counting deployments as normal resources (which they actually are). This would of course span more [sub]chapters than just this one.
Comment 1 Ladislav Thon 2013-10-10 11:02:29 EDT
One of the other chapters that would be affected is the "Role Permissions Matrix". Specifically, the note "[1]" would need to be reworded.
Comment 3 Jakub Cechacek 2014-04-18 04:34:38 EDT
The part of the docs mentioned by lthon in original report seems to be reworked, can you confirm?

If this is ready for QE please change the status appropriately
Comment 11 Ladislav Thon 2015-07-29 10:10:04 EDT
It's been almost two years since I filed this bug, so verifying it was a bit complicated, but yes, the content has been rewritten in a way that addresses this bug.

Verified against:

- Security Guide, Revision 6.4.0-11
- How To Configure Server Security, accessed on Customer Portal 2015-07-29 (no revision number available)

Note You need to log in before you can comment on or make changes to this bug.