Bug 1017816 - Not possible to change UID generation from uuid to socket in EAP config
Not possible to change UID generation from uuid to socket in EAP config
Status: CLOSED DUPLICATE of bug 1036739
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Amos Feng
Ondrej Chaloupka
Russell Dickenson
:
Depends On: 1036739
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 10:43 EDT by Ondrej Chaloupka
Modified: 2013-12-06 08:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When the process ID generation method is changed to process-id-socket-binding instead of process-id-uuid, an error message starting with the following text results: change process-id mechanism from process-id-uuid to process-id-socket-binding on transaction subsystem ---- ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 44) JBAS014613: Operation ("add") failed - address: ([("subsystem" => "transactions")]) - failure description: "JBAS014746: process-id-uuid may not be null" ---- The cause of this issue is that the handling of the configuration parameter is incorrect. This will be resolved in a future release. No workaround is possible, so the default method of process ID generation must be used.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 08:35:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Chaloupka 2013-10-10 10:43:29 EDT
It seems that is not possible to change the type of generation of UID to socket one.

I've tried to put configuration to standalone.xml in the way like
<core-environment>
  <process-id>
    <socket socket-binding="txn-status-manager" />
  </process-id>
</core-environment>

after this change server does not start with parsing error:
ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
 at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.server.ServerService.boot(ServerService.java:324) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:250) [jboss-as-controller-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]
Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[283,13]
Message: JBAS014724: Missing required attribute(s): socket-binding
 at org.jboss.as.controller.parsing.ParseUtils.missingRequired(ParseUtils.java:135) [jboss-as-controller-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.parseRecoveryEnvironmentElement(TransactionSubsystem14Parser.java:445)
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.readElement(TransactionSubsystem14Parser.java:119)
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.readElement(TransactionSubsystem14Parser.java:109)
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.readElement(TransactionSubsystem14Parser.java:53)
 at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
 at org.jboss.staxmapper.XMLExtendedStreamReaderImpl.handleAny(XMLExtendedStreamReaderImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
 at org.jboss.as.server.parsing.StandaloneXml.parseServerProfile(StandaloneXml.java:1024) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_4(StandaloneXml.java:458) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:145) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:107) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
 at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
 at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 ... 3 more
Comment 1 Ondrej Chaloupka 2013-10-10 10:54:06 EDT
Hi, 
I'm really sorry I did a mistake in adding the error. As the bugzilla does not make possible to change the comments I adding the correct error message when server starts with <socket ...> now.
Please, ignore the error in previous comment.



ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 44) JBAS014613: Operation ("add") failed - address: ([("subsystem" => "transactions")]) - failure description: "JBAS014746: process-id-uuid may not be null"                                                                                                                                                                                                                                         
INFO [org.jboss.as.security] (MSC service thread 1-5) JBAS013170: Current PicketBox version=4.0.17.SP2-redhat-2
INFO [org.jboss.as.webservices] (ServerService Thread Pool -- 46) JBAS015537: Activating WebServices Extension
INFO [org.jboss.as.naming] (MSC service thread 1-8) JBAS011802: Starting Naming Service
INFO [org.jboss.as.mail.extension] (MSC service thread 1-4) JBAS015400: Bound mail session [java:jboss/mail/Default]
INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 25) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
INFO [org.apache.coyote.http11] (MSC service thread 1-5) JBWEB003001: Coyote HTTP/1.1 initializing on : http-/127.0.0.1:8080
INFO [org.apache.coyote.http11] (MSC service thread 1-5) JBWEB003000: Coyote HTTP/1.1 starting on: http-/127.0.0.1:8080
INFO [org.jboss.ws.common.management] (MSC service thread 1-6) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.2.1.Final-redhat-3
INFO [org.jboss.as.server.deployment.scanner] (MSC service thread 1-4) JBAS015012: Started FileSystemDeploymentService for directory /home/ochaloup/jboss/jboss-eap-6.2.0.ER5/standalone/deployments
INFO [org.jboss.as.remoting] (MSC service thread 1-2) JBAS017100: Listening on 127.0.0.1:9999
INFO [org.jboss.as.remoting] (MSC service thread 1-7) JBAS017100: Listening on 127.0.0.1:4447
INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
  New missing/unsatisfied dependencies:
    service jboss.txn.ArjunaObjectStoreEnvironment (missing) dependents: [service jboss.txn.ArjunaRecoveryManager] 
    service jboss.txn.ArjunaTransactionManager (missing) dependents: [service jboss.connector.bootstrapcontext.default] 
    service jboss.txn.CoreEnvironment (missing) dependents: [service jboss.txn.ArjunaRecoveryManager, service jboss.ejb.tx-recovery-service] 
    service jboss.txn.JTAEnvironment (missing) dependents: [service jboss.txn.ArjunaRecoveryManager] 
    service jboss.txn.TransactionManager (missing) dependents: [service jboss.ejb3.timerService.fileTimerPersistence, service jboss.ejb.utilities, service jboss.ejb.remote-transactions-repository, service jboss.connector.transactionintegration, JBAS014799: ... and 3 more ] 
    service jboss.txn.TransactionSynchronizationRegistry (missing) dependents: [service jboss.ejb3.timerService.fileTimerPersistence, service jboss.ejb.utilities, service jboss.connector.transactionintegration, service jboss.ejb3.connector, JBAS014799: ... and 2 more ] 
    service jboss.txn.UserTransaction (missing) dependents: [service jboss.ejb.utilities, service jboss.ejb.remote-transactions-repository] 
    service jboss.txn.UserTransactionRegistry (missing) dependents: [service jboss.jpa-usertransactionlistener, service jboss.connector.transactionintegration] 

INFO [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss EAP 6.2.0.Beta1 (AS 7.3.0.Final-redhat-8) started (with errors) in 4187ms - Started 98 of 169 services (14 services failed or missing dependencies, 56 services are passive or on-demand)                                                                                                                                                                                                                               
INFO [org.apache.coyote.http11] (MSC service thread 1-7) JBWEB003075: Coyote HTTP/1.1 pausing on: http-/127.0.0.1:8080
INFO [org.apache.coyote.http11] (MSC service thread 1-7) JBWEB003077: Coyote HTTP/1.1 stopping on : http-/127.0.0.1:8080
INFO [org.apache.catalina.core] (MSC service thread 1-2) JBWEB001079: Container org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/] has not been started
INFO [org.jboss.as.controller] (MSC service thread 1-5) JBAS014774: Service status report
  Newly corrected services:
    service jboss.txn.ArjunaObjectStoreEnvironment (no longer required)
    service jboss.txn.ArjunaTransactionManager (no longer required)
    service jboss.txn.CoreEnvironment (no longer required)
    service jboss.txn.JTAEnvironment (no longer required)
    service jboss.txn.TransactionManager (no longer required)
    service jboss.txn.TransactionSynchronizationRegistry (no longer required)
    service jboss.txn.UserTransaction (no longer required)
    service jboss.txn.UserTransactionRegistry (no longer required)

INFO [org.jboss.as] (MSC service thread 1-6) JBAS015950: JBoss EAP 6.2.0.Beta1 (AS 7.3.0.Final-redhat-8) stopped in 46ms
~/jboss/jboss-eap-6.2.0.ER5$ vim standalone/configuration/standalone.xml
~/jboss/jboss-eap-6.2.0.ER5$ ./bin/standalone.sh 
=========================================================================

 JBoss Bootstrap Environment

 JBOSS_HOME: /home/ochaloup/jboss/jboss-eap-6.2.0.ER5

 JAVA: /opt/oracle-jdk7-last/bin/java

 JAVA_OPTS: -server -XX:+UseCompressedOops -Xms1303m -Xmx1303m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true

=========================================================================

INFO [org.jboss.modules] (main) JBoss Modules version 1.3.0.Final-redhat-2
INFO [org.jboss.msc] (main) JBoss MSC version 1.0.4.GA-redhat-1
INFO [org.jboss.as] (MSC service thread 1-8) JBAS015899: JBoss EAP 6.2.0.Beta1 (AS 7.3.0.Final-redhat-8) starting
 ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
 at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.server.ServerService.boot(ServerService.java:324) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:250) [jboss-as-controller-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]
 by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[277,21]
 JBAS014789: Unexpected element '{urn:jboss:domain:transactions:1.4}uuid' encountered
 at org.jboss.as.controller.parsing.ParseUtils.unexpectedElement(ParseUtils.java:86) [jboss-as-controller-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.parseProcessIdEnvironmentElement(TransactionSubsystem14Parser.java:369)
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.parseCoreEnvironmentElement(TransactionSubsystem14Parser.java:339)
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.readElement(TransactionSubsystem14Parser.java:123)
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.readElement(TransactionSubsystem14Parser.java:109)
 at org.jboss.as.txn.subsystem.TransactionSubsystem14Parser.readElement(TransactionSubsystem14Parser.java:53)
 at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
 at org.jboss.staxmapper.XMLExtendedStreamReaderImpl.handleAny(XMLExtendedStreamReaderImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
 at org.jboss.as.server.parsing.StandaloneXml.parseServerProfile(StandaloneXml.java:1024) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_4(StandaloneXml.java:458) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:145) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:107) [jboss-as-server-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
 at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
 at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.3.0.Final-redhat-8.jar:7.3.0.Final-redhat-8]
 ... 3 more
 
 FATAL [org.jboss.as.server] (Controller Boot Thread) JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.
Comment 4 Ondrej Chaloupka 2013-12-02 10:05:24 EST
It was found this mistake and proposes the fix. Check the bz#1036739.
Comment 5 tom.jenkinson 2013-12-06 08:12:43 EST
Should we close one of these as a duplicate?
Comment 6 Ondrej Chaloupka 2013-12-06 08:35:04 EST
Closing as it's duplicate issue of the newly reported one where resides info about the patch.

*** This bug has been marked as a duplicate of bug 1036739 ***

Note You need to log in before you can comment on or make changes to this bug.