Bug 1017828 - Accessing /task_groups/<task.task_group_id>/<task.task_id>/ gives a 404
Accessing /task_groups/<task.task_group_id>/<task.task_id>/ gives a 404
Status: CLOSED WONTFIX
Product: Pulp
Classification: Community
Component: API/integration (Show other bugs)
2.2
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: pulp-bugs
pulp-qe-list
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 11:03 EDT by mkovacik
Modified: 2015-02-02 09:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-02 09:44:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen log (7.62 KB, text/plain)
2013-10-10 11:03 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2013-10-10 11:03:42 EDT
Created attachment 810602 [details]
screen log

Description of problem:
Accessing /task_groups/<task.task_group_id>/<task.task_id>/ gives a 404; Although the reproducer below concerns a repo DELETE request, tasks resulting from sync requests behave the same

Version-Release number of selected component (if applicable):
Pulp 2.2

How reproducible:
Always

Steps to Reproduce:
1. create a custom repo
2. delete the custom repo
3. do "curl -kvL  https://admin:admin@pulp.example.com/pulp/api/v2/tasks/ | python -mjson.tool" to get list of tasks
4. do "curl -kvL https://admin:admin@pulp.example.com/pulp/api/v2/task_groups/<task.task_group_id>/<task.task_id>/ | python -mjson.tool" to access particular task details


Actual results:
/task_groups/<task.task_group_id>/<task.task_id>/ gives a 404;

Expected results:
/task_groups/<task.task_group_id>/<task.task_id>/ gives a 200 with json representation of a task item in data

Additional info:
See also attached screen log
Comment 1 Jason Connor 2013-10-10 11:26:30 EDT
The task group REST API only manipulates the task "group" resource. Individual tasks are available through the tasks REST API.

https://pulp-dev-guide.readthedocs.org/en/pulp-2.2/integration/rest-api/dispatch/task.html

https://pulp-dev-guide.readthedocs.org/en/pulp-2.2/integration/rest-api/dispatch/group.html

The URL returns a 404 because it doesn't exist.
Comment 2 mkovacik 2013-10-10 11:38:35 EDT
Why does then the GET call data contain a _href field pointing me to a group then?:
/pulp/api/v2/task_groups/d37e8d8d-59e1-4775-9549-b8084e40be93/

What's the point of grouping the tasks when I can't access them by their task_group_id/task_id attributes?
Comment 3 amacdona@redhat.com 2015-02-02 09:44:46 EST
The /v2/task_groups/ endpoints were removed in Pulp 2.4.

http://pulp.readthedocs.org/en/latest/user-guide/release-notes/2.4.x.html#other-changes

Note You need to log in before you can comment on or make changes to this bug.