Bug 1017889 - sddm selinux issues
sddm selinux issues
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 13:20 EDT by Orion Poplawski
Modified: 2014-07-25 16:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-25 16:29:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-10-10 13:20:49 EDT
Description of problem:

/usr/bin/sddm is labeled bin_t and runs in initrc_t.  Presumably it should be labeled xdm_exec_t.

When labeled xdm_exec_t I see the following denials in permissive mode:

type=AVC msg=audit(1381425470.880:160): avc:  denied  { write } for  pid=1226 comm="xauth" name="sddm" dev="tmpfs" ino=11273 scontext=system_u:system_r:xauth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=dir
type=AVC msg=audit(1381425470.880:160): avc:  denied  { add_name } for  pid=1226 comm="xauth" name="A:0-Lsrash-c" scontext=system_u:system_r:xauth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=dir
type=AVC msg=audit(1381425470.880:160): avc:  denied  { create } for  pid=1226 comm="xauth" name="A:0-Lsrash-c" scontext=system_u:system_r:xauth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file
type=AVC msg=audit(1381425470.880:160): avc:  denied  { open } for  pid=1226 comm="xauth" path="/run/sddm/A:0-Lsrash-c" dev="tmpfs" ino=20485 scontext=system_u:system_r:xauth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file
type=AVC msg=audit(1381425470.881:161): avc:  denied  { link } for  pid=1226 comm="xauth" name="A:0-Lsrash-c" dev="tmpfs" ino=20485 scontext=system_u:system_r:xauth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file
type=AVC msg=audit(1381425470.882:162): avc:  denied  { remove_name } for  pid=1226 comm="xauth" name="A:0-Lsrash-n" dev="tmpfs" ino=20486 scontext=system_u:system_r:xauth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=dir
type=AVC msg=audit(1381425470.882:162): avc:  denied  { unlink } for  pid=1226 comm="xauth" name="A:0-Lsrash-n" dev="tmpfs" ino=20486 scontext=system_u:system_r:xauth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file
type=AVC msg=audit(1381425470.947:163): avc:  denied  { open } for  pid=1229 comm="sddm-greeter" path="/run/sddm/A:0-Lsrash" dev="tmpfs" ino=20486 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file
type=AVC msg=audit(1381425470.947:164): avc:  denied  { getattr } for  pid=1229 comm="sddm-greeter" path="/run/sddm/A:0-Lsrash" dev="tmpfs" ino=20486 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file

Version-Release number of selected component (if applicable):
selinux-policy-3.12.1-75.fc20.noarch
Comment 1 Orion Poplawski 2014-07-25 16:29:39 EDT
Looks like this got fixed a while back.

Note You need to log in before you can comment on or make changes to this bug.