Bug 1017924 - Syncing content to a child node is taking a very long time
Syncing content to a child node is taking a very long time
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Corey Welton
: Triaged
Depends On:
Blocks: 1018885
  Show dependency treegraph
 
Reported: 2013-10-10 15:28 EDT by Brad Buckingham
Modified: 2014-09-11 08:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1018885 (view as bug list)
Environment:
Last Closed: 2014-09-11 08:20:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2013-10-10 15:28:41 EDT
Description of problem:

Unfortunately, until more details are uncovered this bugzilla will be a bit vague.  That said, it has been observed that syncing a large repo from a pulp master (Satellite 6) to a node (Satellite 6 node) is taking a very long time.  For example, syncing a 6Server repo (consisting of ~11K pkgs and ~16G of content) has been observed to take more than ~16hours.

Version-Release number of selected component (if applicable):

katello-1.4.6-21.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-admin-extensions-2.3.0-0.16.alpha.el6.noarch
node-installer-0.0.15-2.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch

How reproducible:
Always (so far)

Steps to Reproduce:
1. Install/configure Satellite 6 (katello-configure)
2. Import a manifest, enable & sync RHEL 6Server
3. Create a content view definition, adding the repo from 3
4. Publish a content view from the definition

5. Install/configure Satellite 6 node (node-installer)
6. Using the CLI on the Satellite 6, add Library to the node.  E.g, 
   node add_environment --org Katello_Infrastructure --environment Library --id 1
7. Sync the Library to the node
   node sync --org Katello_Infrastructure --environment Library --id 1

Actual results:
content synced for ~16 hrs...

Expected results:
Based on discussions, it should have completed much quicker (e.g. 20min to 1hr)

Additional info:
Comment 2 Brad Buckingham 2013-10-11 07:08:54 EDT
Attempted another sync from a separate Satellite 6 master to a node.  The content synced was the 6Server repo (~16G content) and it took over 16 hours to complete.
Comment 3 Jeff Ortel 2013-10-11 18:51:47 EDT
https://github.com/pulp/pulp/pull/660
Comment 4 Jeff Ortel 2013-10-11 21:53:37 EDT
build: pulp 2.3.0-0.19.beta
Comment 5 Brad Buckingham 2013-10-13 07:53:02 EDT
Using the latest builds for Satellite 6 MDP2, installed and configured a sat6 server and node.  Then updated the following packages on the child node:
   pulp-nodes-common-2.3.0-0.19.beta.el6.noarch
   pulp-nodes-child-2.3.0-0.19.beta.el6.noarch

Afterwards:
-imported a manifest
-enabled the RHEL 6.4 kickstart repo and server rpms repo
-synced the above repos (~14,600 rpms)
-added them to a content view definition
-published a view
-promoted the view to dev env

-added the dev env to the child node
-synced the dev env to the child node

While this is not an exact duplication of the original test case (i.e.dev vs library, 6.4 vs 6Server), the sync did include ~14K+ rpms across 2 repos.  

The sync appears to have completed successfully in ~35 minutes vs hours.
Comment 8 Corey Welton 2014-08-27 20:39:45 EDT
This seems to be better in Satellite-6.0.4-RHEL-6-20140823.0.  Things sync a lot faster now.
Comment 9 Bryan Kearney 2014-09-11 08:20:38 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.