Bug 1017944 - Making (test) calls with Skype produces noise on Lenovo X1 Carbon
Making (test) calls with Skype produces noise on Lenovo X1 Carbon
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 16:18 EDT by Dominik Grafenhofer
Modified: 2014-01-12 08:29 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 03:21:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik Grafenhofer 2013-10-10 16:18:59 EDT
When initiating the a call on my Lenovo X1 Carbon, there is no sound output. Even the skype test sound does not play. The pulseaudio settings seem ok, other applications like empathy work fine. After hanging up and calling again I get loud noise (not white noise, but heavily distorted). This noise does not go away by hanging up. I have to shutdown skype to get rid of the noise.

The problem is present using internal and external microphone/speakers. Skype works well under Ubuntu 13.04. The result does not depend on the source of the Skype package (rpm+tar from skype.com, rpm for FC-20 from http://negativo17.org/skype-and-skype-pidgin-plugin/).


F-20 alpha + all updates:

pulseaudio-4.0-4.gita89ca
pulseaudio-libs-4.0-4.gita89ca
alsa-plugins-pulseaudio-1.0.27
alsa-lib-1.0.27.2-2
kernel-3.11.3-301

Steps to Reproduce:
1. Make Skype (test) call. Notice that sound (output) does not work. Hang up.
2. Make Skype (test) call. Noice/heavily distorted sound output

lspci -v:

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
Subsystem: Lenovo Device 21f9
Flags: bus master, fast devsel, latency 0, IRQ 47
Memory at f1510000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Comment 1 D. Charles Pyle 2013-10-10 16:36:32 EDT
Skype is doing the same thing on a Dell Inspiron 560, running Fedora 20-Alpha.

This did not occur until the last spate of updates to various codecs and pulseaudio.

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
	Subsystem: Dell Device 0439
	Flags: bus master, fast devsel, latency 0, IRQ 46
	Memory at f7df8000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [100] Virtual Channel
	Capabilities: [130] Root Complex Link
	Kernel driver in use: snd_hda_intel
Comment 2 Rex Dieter 2013-10-10 17:22:34 EDT
See 
http://community.skype.com/t5/Linux/Crackling-and-unusable-sound-with-pulseaudio-4-0-proposed-fix/td-p/1683361

which includes a workaround until skype is fixed.

Note You need to log in before you can comment on or make changes to this bug.