Bug 1017965 - Enable testsuite during build in %check phase for autoconf213
Enable testsuite during build in %check phase for autoconf213
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: autoconf213 (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Raiskup
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 16:57 EDT by Pavel Raiskup
Modified: 2014-06-18 01:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:31:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2013-10-10 16:57:37 EDT
I recently enabled testsuite for autoconf213 (which is still needed to rebuild
firefox and some related projects) in Fedora Rawhide.  This bug is mentioned
to ask QA whether they think that it does make sense to enable the testsuite
also in RHEL7 or not for this legacy tool (this action requires respin); and
to track the enablement if yes.  Note that the package shouldn't be used by
our customers.

I know that there are concerns to enable upstream testsuites if possible, I'm
just not sure if we should do it really everywhere.

This bug may be closed by QA as WONTFIX, if there is no need to do so.
Comment 2 Martin Cermak 2013-10-11 03:35:49 EDT
From my point it's definitely useful to have the testsuite enabled by default: This way eventual issues will appear right at the build time. Creating an erratum just because of this doesn't seem reasonable to me, but please do so once some erratum for this component comes. Thanks.
Comment 7 Ludek Smid 2014-06-13 08:31:24 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.