Bug 1018011 - NFS (nfs-utils 1.2.8-6.0) server doesn't allow some clients to connect [NEEDINFO]
NFS (nfs-utils 1.2.8-6.0) server doesn't allow some clients to connect
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 20:59 EDT by Felipe Ferreri Tonello
Modified: 2014-12-22 15:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-22 15:39:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
steved: needinfo? (eu)


Attachments (Terms of Use)

  None (edit)
Description Felipe Ferreri Tonello 2013-10-10 20:59:01 EDT
Description of problem:
NFS server doesn't allows some clients to connect.

Version-Release number of selected component (if applicable):
1.2.8-6.0

How reproducible:
I have a Linux 2.6.36 for ARM that mounts a rootfs using NFS. My kernel as the following parameters: ip=dhcp root=/dev/nfs nfsroot=server-ip:/nfs/rootfs.

Steps to Reproduce:
1. Have an older kernel 2.6.36
2. Use those parameters to mount a rootfs via NFS
3.

Actual results:
Since the update I wasn't able to connect to the server.

Kernel log:

[    5.498078] Sending DHCP requests .., OK
[    7.678072] IP-Config: Got DHCP answer from 0.0.0.0, my address is 192.168.48.117
[    7.682840] IP-Config: Complete:
[    7.683052]      device=eth0, addr=192.168.48.117, mask=255.255.248.0, gw=192.168.55.254,
[    7.691045]      host=192.168.48.117, domain=my-domain, nis-domain=(none),
[    7.698639]      bootserver=0.0.0.0, rootserver=192.168.48.130, rootpath=
[    7.706060] Looking up port of RPC 100003/2 on 192.168.48.130
[    7.714008] Looking up port of RPC 100005/1 on 192.168.48.130
[    7.721590] VFS: Unable to mount root fs via NFS, trying floppy.
[    7.723748] VFS: Cannot open root device "nfs" or unknown-block(2,0)
[    7.729193] Please append a correct "root=" boot option; here are the available partitions:
[    7.737612] b300         7798784 mmcblk0 driver: mmcblk
[    7.742670]   b301         2097152 mmcblk0p1
[    7.746920]   b302         4194304 mmcblk0p2
[    7.751168] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
[    7.759524] [<c0139f00>] (unwind_backtrace+0x0/0xe0) from [<c04bc5f0>] (panic+0x58/0x17c)
[    7.767654] [<c04bc5f0>] (panic+0x58/0x17c) from [<c0009000>] (mount_block_root+0x1cc/0x210)
[    7.776055] [<c0009000>] (mount_block_root+0x1cc/0x210) from [<c00093a4>] (prepare_namespace+0x160/0x1c0)
[    7.785597] [<c00093a4>] (prepare_namespace+0x160/0x1c0) from [<c0008c64>] (kernel_init+0x1cc/0x214)
[    7.794705] [<c0008c64>] (kernel_init+0x1cc/0x214) from [<c0135254>] (kernel_thread_exit+0x0/0x8)
[    7.803763] CPU1: stopping
[    7.803842] [<c0139f00>] (unwind_backtrace+0x0/0xe0) from [<c0133384>] (do_IPI+0xe0/0x14c)
[    7.803917] [<c0133384>] (do_IPI+0xe0/0x14c) from [<c0133b5c>] (__irq_svc+0x5c/0xf8)
[    7.803958] Exception stack(0xde055f98 to 0xde055fe0)
[    7.803997] 5f80:                                                       00000001 00000007
[    7.804060] 5fa0: de055fe0 00000000 de054000 c04c51f0 c06c64c8 c06c661c ffffffff 412fc091
[    7.804122] 5fc0: 0000001f 00000000 00000000 de055fe0 c0140714 c0140718 60000013 ffffffff
[    7.804202] [<c0133b5c>] (__irq_svc+0x5c/0xf8) from [<c0140718>] (s5pv310_idle+0x24/0x28)
[    7.804278] [<c0140718>] (s5pv310_idle+0x24/0x28) from [<c01354fc>] (cpu_idle+0x7c/0xd0)
[    7.804342] [<c01354fc>] (cpu_idle+0x7c/0xd0) from [<40008080>] (0x40008080)

Expected results:
Connect to NFS server and mount the rootfs.

Additional info:
I solved this problem by downgrading this package to 1.2.8-2.0.fc19
Comment 1 J. Bruce Fields 2013-10-11 10:26:29 EDT
If you modify /etc/sysconfig/nfs to add "-V2" to the nfsd commandline:

  RPCNFSDARGS="-V2"

and then restart nfsd, does that fix the problem?
Comment 2 Felipe Ferreri Tonello 2014-12-22 12:24:44 EST
I am sorry, but I cannot reproduce this bug anymore since I don't have access to the ARM device as mentioned.

Note You need to log in before you can comment on or make changes to this bug.