Bug 1018032 (CVE-2013-4408) - CVE-2013-4408 samba: Heap-based buffer overflow due to incorrect DCE-RPC fragment length field check
Summary: CVE-2013-4408 samba: Heap-based buffer overflow due to incorrect DCE-RPC frag...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2013-4408
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1018033 1018034 1018035 1018036 1018037 1018038 1018039 1018040 1018041 1020116 1039454
Blocks: 1016554
TreeView+ depends on / blocked
 
Reported: 2013-10-11 04:06 UTC by Huzaifa S. Sidhpurwala
Modified: 2021-02-17 07:17 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-06 19:10:54 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2013:1805 0 normal SHIPPED_LIVE Important: samba4 security update 2013-12-10 04:37:26 UTC
Red Hat Product Errata RHSA-2013:1806 0 normal SHIPPED_LIVE Important: samba and samba3x security update 2013-12-10 05:17:45 UTC
Red Hat Product Errata RHSA-2014:0009 0 normal SHIPPED_LIVE Important: samba security update 2014-01-06 23:32:39 UTC

Description Huzaifa S. Sidhpurwala 2013-10-11 04:06:20 UTC
It was found that samba versions 3.4.0 and above was vulnerable to heap-based buffer overflow flaw, in the client processing of DCE-RPC packets. This is due to incorrect checking of the DCE-RPC fragment length in the client code.

The DCE-RPC client code is part of the winbindd authentication and identity mapping daemon, which is commonly configured as part of many server installations (when joined to an Active Directory Domain). A malicious Active Directory Domain Controller or man-in-the-middle attacker impersonating an Active Directory Domain Controller could achieve root-level access by compromising the winbindd process.

As per upstream:

Samba server versions 3.4.0 - 3.4.17 and versions 3.5.0 - 3.5.22 are also vulnerable to a denial of service attack (server crash) due to a similar error in the server code of those versions.

Samba server versions 3.6.0 and above (including all 3.6.x versions, all 4.0.x versions and 4.1.0) are not vulnerable to this problem.

Upstream flaw bug:
https://bugzilla.samba.org/show_bug.cgi?id=10185

Comment 1 Huzaifa S. Sidhpurwala 2013-10-11 04:11:05 UTC
Acknowledgements:

Red Hat would like to thank the Samba project for reporting this issue.
Upstream acknowledges Stefan Metzmacher and Michael Adam of SerNet as the
original reporters of this issue.

Comment 9 Huzaifa S. Sidhpurwala 2013-12-09 05:51:19 UTC
Statement:

This issue does not affect the version of samba as shipped with Red Hat Enterprise Linux 5.

Comment 10 Huzaifa S. Sidhpurwala 2013-12-09 05:52:07 UTC
Public via:

http://www.samba.org/samba/security/CVE-2013-4408

Comment 11 Huzaifa S. Sidhpurwala 2013-12-09 06:58:42 UTC
Created samba tracking bugs for this issue:

Affects: fedora-all [bug 1039454]

Comment 12 errata-xmlrpc 2013-12-09 23:38:05 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2013:1805 https://rhn.redhat.com/errata/RHSA-2013-1805.html

Comment 13 errata-xmlrpc 2013-12-10 00:18:33 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5
  Red Hat Enterprise Linux 6

Via RHSA-2013:1806 https://rhn.redhat.com/errata/RHSA-2013-1806.html

Comment 14 errata-xmlrpc 2014-01-06 18:34:22 UTC
This issue has been addressed in following products:

  Red Hat Storage 2.1

Via RHSA-2014:0009 https://rhn.redhat.com/errata/RHSA-2014-0009.html


Note You need to log in before you can comment on or make changes to this bug.