Bug 1018080 - unexpanded systemd-macros in rpm-scriptlets
unexpanded systemd-macros in rpm-scriptlets
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: trafficserver (Show other bugs)
19
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
: 1018117 (view as bug list)
Depends On:
Blocks: 1018118
  Show dependency treegraph
 
Reported: 2013-10-11 03:21 EDT by Ralf Corsepius
Modified: 2015-02-17 18:37 EST (History)
2 users (show)

See Also:
Fixed In Version: trafficserver-3.2.5-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-20 21:03:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2013-10-11 03:21:39 EDT
Description of problem:

trafficserver for Fedora >= 19 contains broken rpm-scriptlets,
which contain unexpanded systemd-macros:

# rpm -q --scripts -p trafficserver-3.2.5-3.fc19.x86_64.rpm 
preinstall scriptlet (using /bin/sh):
getent group ats >/dev/null || groupadd -r ats -g 176 &>/dev/null
getent passwd ats >/dev/null || \
useradd -r -u 176 -g ats -d / -s /sbin/nologin \
	-c "Apache Traffic Server" ats &>/dev/null
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
  %systemd_post trafficserver.service
preuninstall scriptlet (using /bin/sh):
  %systemd_preun trafficserver.service
postuninstall scriptlet (using /bin/sh):
/sbin/ldconfig

  %systemd_postun_with_restart trafficserver.service


Additional info:
- The cause of this issue is the spec missing a BR: systemd to pull-in the
necessary systemd.macros.
- These unexpanded systemd macros may cause yum update failures, leaving behind
duplicate entries in rpmdb.
Comment 1 Ralf Corsepius 2013-10-11 03:23:03 EDT
I am going to apply patches to f19, f20 and rawhide.
Comment 2 Fedora Update System 2013-10-11 03:57:08 EDT
trafficserver-3.2.5-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/trafficserver-3.2.5-4.fc19
Comment 3 Fedora Update System 2013-10-11 03:57:48 EDT
trafficserver-4.0.2-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/trafficserver-4.0.2-3.fc20
Comment 4 Fedora Update System 2013-10-11 19:56:55 EDT
Package trafficserver-3.2.5-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing trafficserver-3.2.5-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18905/trafficserver-3.2.5-4.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-20 21:03:14 EDT
trafficserver-3.2.5-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-11-10 01:20:30 EST
trafficserver-4.0.2-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Florian Weimer 2015-02-17 18:37:20 EST
*** Bug 1018117 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.