Bug 1018091 - Votequorum module logs as QUORUM instead of VOTEQ
Votequorum module logs as QUORUM instead of VOTEQ
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libqb (Show other bugs)
7.0
All All
unspecified Severity low
: rc
: ---
Assigned To: David Vossel
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 04:04 EDT by Christine Caulfield
Modified: 2014-06-18 03:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: libqb-0.16.0-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:00:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2013-10-11 04:04:37 EDT
Description of problem:

If I enable votequorum logging in corosync.conf as below, the log messages come tagged as [QUORUM] instead of [VOTEQ]

logging {
  to_syslog: yes
  logger_subsys {
        subsys: VOTEQ
        debug: on
        }
}


Version-Release number of selected component (if applicable):
7.0

How reproducible:
Every time

Steps to Reproduce:
1. Add logging stanza to corosync.conf
2. Enable debug logging in rsyslog.conf
3. read syslog file

Actual results:
votequorum log messages come out prefixed with [QUORUM]

Oct 10 16:45:43 localhost corosync[9666]: [QUORUM] got nodeinfo message from cluster node 4
Oct 10 16:45:43 localhost corosync[9666]: [QUORUM] nodeinfo message[0]: votes: 0, expected: 0 flags: 0
Oct 10 16:45:43 localhost corosync[9666]: [QUORUM] total_votes=4, expected_votes=4
Oct 10 16:45:43 localhost corosync[9666]: [QUORUM] node 1 state=1, votes=1, expected=4
Oct 10 16:45:43 localhost corosync[9666]: [QUORUM] node 2 state=1, votes=1, expected=4
Oct 10 16:45:43 localhost corosync[9666]: [QUORUM] node 3 state=1, votes=1, expected=4
Oct 10 16:45:43 localhost corosync[9666]: [QUORUM] node 4 state=1, votes=1, expected=4
Oct 10 16:45:43 localhost corosync[9666]: [QUORUM] lowest node id: 1 us: 2


Expected results:
Log messages should match the subsystem requested in corosync.conf. In this case [VOTEQ ]


Additional info:
Comment 2 Christine Caulfield 2013-10-11 11:56:52 EDT
I have narrowed this down to what I think is a libqb bug (or maybe a feature).

it seems the file matching algorithm in log.c function _cs_matches_filter_ doesn't distinguish between votequorum.c and quorum.c because the latter is contained in the former. If there are some quorum.c filters defined AFTER votequorum.c filters then they get applied and the tags get set to 1 [QUORUM] instead of 7 [VOTEQ ]

Ping me on IRC if you need more information.
Comment 3 Christine Caulfield 2013-10-14 03:57:12 EDT
libqb issue ref: https://github.com/ClusterLabs/libqb/issues/94
Comment 4 David Vossel 2013-10-17 17:53:30 EDT
There is now an upstream patch related to this issue.

https://github.com/ClusterLabs/libqb/commit/9abb68637d6d448cccfa06daa05d9c5bf59f5d3e
Comment 7 Ludek Smid 2014-06-13 09:00:45 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.