Bug 1018093 - Brand change commits in the product branch should be replaced by a flag in the community build
Brand change commits in the product branch should be replaced by a flag in th...
Status: CLOSED WONTFIX
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Edson Tirelli
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 04:18 EDT by Geoffrey De Smet
Modified: 2015-01-08 11:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-08 11:50:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoffrey De Smet 2013-10-11 04:18:27 EDT
The brand change commits (which are only in the product git repository, not the community git repository) are a pain, because to continually have to rebased/merged when the community git repo is synced to the product git repo.

Here's a proposed solution:
- The community build support a flag, for example -Dproductization=true. The BREW builds etc turn that flag on (and any community work leaves it off).
- The build will choose based upon that flag which logo's and names etc to use inside the apps and documentation.

Potential problems:
- The branded logo might not be uploaded to the community GitHub repository. We should check if we can upload it and just override the license for that directory. If this is not possible, the logo's might be able to come form a hardcoded path only available on brew...
- variable substitution documentation isn't pretty
- variable substitution in java files is impossible: the java code must fetch the variables from a properties file and the build must use maven filtering to fill those properties files correctly.


How to make an inventory of the branding changes:
<etirelli> all branding fixes are in the branding branch in the 3 repos affected
<etirelli> git diff branding.2013.10.02...6.0.x -----> execute this in the 3 repos affected
Comment 5 Lukáš Petrovický 2013-11-12 08:37:43 EST
Changing component to better reflect reality.
Comment 6 Geoffrey De Smet 2014-09-29 10:12:22 EDT
Assigning back to Edson, he's been looking at this issue and trying to get some movement in it.
Comment 7 Kris Verlaenen 2015-01-08 11:50:52 EST
Branding commits have been added to the community repo.

Note You need to log in before you can comment on or make changes to this bug.