Bug 101810 - trn requires /etc/HOSTNAME, but this configuration file isn't setup
trn requires /etc/HOSTNAME, but this configuration file isn't setup
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: trn (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-07 00:39 EDT by borchers
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 12:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description borchers 2003-08-07 00:39:53 EDT
Description of problem:

Red Hat 9 contains trn-3.6-21 as an rpm package.  However, the install 
process leaves the system without an /etc/HOSTNAME file, and trn requires 
this file.

Version-Release number of selected component (if applicable):


How reproducible:

Just try running trn!

Steps to Reproduce:
1. run trn
    
Actual results:

>trn
Warning: Couldn't open /etc/HOSTNAME to determine hostname!

Caught an internal error--.newsrc restored   
Expected results:

trn should run normally.  (Note that you'll need to set the NNTPSERVER
environment variable to the name of an available NNTP server.)  

Additional info:

The basic problem here is that trn doesn't use "gethostname", but 
rather looks in /etc/HOSTNAME.  

Setting up /etc/HOSTNAME would probably be generally helpful to other
packages which expect the file to be present.  

It would also be trivial to patch trn to use "gethostname"  However, I'm not 
sure whether anyone is actively maintaining this software any more.
Comment 1 Jeff Johnson 2003-08-19 12:32:03 EDT
Put a hostname in /etc/HOSTNAME to configure.

Trying to retrofit a more reasonable convention for
a program as old as trn is hardly worth the effort.
The issue is not as simple as just using gethostname,
as trn posts, and users often want their posts to appear
as originating from a domain, not from a host.

Note You need to log in before you can comment on or make changes to this bug.