Bug 1018131 - php-pear: unexpanded RPM macro in %triggerpostun
php-pear: unexpanded RPM macro in %triggerpostun
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: php-pear (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Web Stack Team
Petr Šplíchal
: Triaged
Depends On:
Blocks: 1018118
  Show dependency treegraph
 
Reported: 2013-10-11 05:56 EDT by Florian Weimer
Modified: 2016-05-31 21:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:34:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-10-11 05:56:04 EDT
The spec file has this:

%triggerpostun -- php-pear-XML-Util
# re-register extension unregistered during postun of obsoleted php-pear-XML-Util
%{_bindir}/pear install --nodeps --soft --force --register-only %{pear_xmldir}/XML_Util.xml >/dev/null || :

There is a macros file which defines pear_xmldir, but it is apparently not used while building the package, so the macro reference is not expanded.

I've seen this with php-pear-1:1.9.4-4.el6.noarch.
Comment 2 Remi Collet 2013-10-11 07:15:16 EDT
The pear_xmldir is define by the macros.pear file, owned by php-pear (so of course not available at build time).

Verified:

# rpm -q php-pear
php-pear-1.9.4-4.el6.noarch
# rpm -q --triggers php-pear
triggerpostun scriptlet (using /bin/sh) -- php-pear-XML-Util
# re-register extension unregistered during postun of obsoleted php-pear-XML-Util
/usr/bin/pear install --nodeps --soft --force --register-only %{pear_xmldir}/XML_Util.xml >/dev/null || :


I think this trigger (inherited from fedora time) could be remove.
It will never be used as designed to handle update from pear without XML-Util, which is Fedora specific.

Simple fix:

%triggerpostun -- php-pear-XML-Util
# re-register extension unregistered during postun of obsoleted php-pear-XML-Util
%{_bindir}/pear install --nodeps --soft --force --register-only  \
   %{peardir}/.pkgxml/XML_Util.xml >/dev/null || :
Comment 3 RHEL Product and Program Management 2013-10-13 19:00:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 14 errata-xmlrpc 2016-05-10 16:34:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0795.html

Note You need to log in before you can comment on or make changes to this bug.