Bug 1018144 - RFE [Cinder]: Make volume connections editable
RFE [Cinder]: Make volume connections editable
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: RFEs (Show other bugs)
4.0
x86_64 Linux
unspecified Severity high
: ---
: 5.0 (RHEL 7)
Assigned To: RHOS Maint
storage
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 06:40 EDT by Dafna Ron
Modified: 2014-09-08 01:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-25 07:17:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1238593 None None None Never

  None (edit)
Description Dafna Ron 2013-10-11 06:40:28 EDT
Description of problem:

In the past few days I have been working on cinder with gluster backend. 
I have encountered some major issues in how cinder works with mounts during a failure on gluster storage side. 
 
some of the issues are nfs stale connections, cinder-volume service crashing when cannot reach a share, cinder db refresh. 

speaking to eharney he said that he has been thinking that perhaps it would be a good idea to axe the shares file cinder is using and manage the mounts with API calls. 

I think this would be a good idea so opening an RFE for this. 

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. install cinder with gluster backend
2. shut down the gluster servers
3. re-run packstack with a new gluster mount point on a new server

Actual results:

cinder will still try to mount old and new shares. 
since the old share is gone, cinder will crash and we need to manually remove the share from cinder db to continue working

Expected results:

we should have a way to manage mounts in cinder without using a share file so that managing mounts can be easier and cinder will not crash if we have a failed mount. 

Additional info:

Note You need to log in before you can comment on or make changes to this bug.