Bug 1018157 - perl-Test-Harness-3.29 is available
perl-Test-Harness-3.29 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Test-Harness (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 06:52 EDT by Upstream Release Monitoring
Modified: 2013-10-14 05:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Test-Harness-3.29-1.fc21
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 05:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2013-10-11 06:52:51 EDT
Latest upstream release: 3.29
Current version/release in Fedora Rawhide: 3.28-3.fc20
URL: http://search.cpan.org/dist/Test-Harness/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Paul Howarth 2013-10-11 06:58:52 EDT
I'm going to need this for the current version of Module::Build::Tiny, so a buildroot override in F-20 would be nice when the update's ready.
Comment 2 Petr Pisar 2013-10-14 03:19:22 EDT
(In reply to Paul Howarth from comment #1)
> I'm going to need this for the current version of Module::Build::Tiny, so a
> buildroot override in F-20 would be nice when the update's ready.

I do not want to push this into F20 because this Test-Harness release breaks API, it removes TAP::Parser::Utils module.

Do you have a serious reason why to break API?
Comment 3 Paul Howarth 2013-10-14 04:30:43 EDT
(In reply to Petr Pisar from comment #2)
> (In reply to Paul Howarth from comment #1)
> > I'm going to need this for the current version of Module::Build::Tiny, so a
> > buildroot override in F-20 would be nice when the update's ready.
> 
> I do not want to push this into F20 because this Test-Harness release breaks
> API, it removes TAP::Parser::Utils module.
> 
> Do you have a serious reason why to break API?

Well only that the new TAP::Harness::Env module is needed by Module::Build::Tiny, and some upstream authors (notably Karen Etheridge who works on lots of toolchain modules) always seem to specify the current version of Module::Build::Tiny whenever they release a new version of a module that uses it (perhaps this is the work of a dzil plugin?). The new version of Test::Warnings asks for the current version for instance.

Also I can't see anything in Fedora that requires TAP::Parser::Utils.

However, if you feel it's too late in the F20 cycle to make this change, I could probably patch around the requirement for current Module::Build::Tiny versions as and when necessary,
Comment 4 Petr Pisar 2013-10-14 05:26:56 EDT
I think it's to late for F20.

Note You need to log in before you can comment on or make changes to this bug.