Bug 1018176 - Memory leak in gluster samba vfs / libgfapi
Memory leak in gluster samba vfs / libgfapi
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ric Wheeler
Sudhir D
: ZStream
Depends On: 1011313
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 07:20 EDT by Poornima G
Modified: 2014-04-17 07:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1011313
Environment:
Last Closed: 2014-04-17 07:49:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-10-11 07:28:42 EDT
REVIEW: http://review.gluster.org/6074 (gfapi: Fix iobuf leaks in gfapi) posted (#1) for review on master by poornima g (pgurusid@redhat.com)
Comment 2 Anand Avati 2013-10-11 15:06:02 EDT
COMMIT: http://review.gluster.org/6074 committed in master by Anand Avati (avati@redhat.com) 
------
commit d3558ae5c4b1cf6909e27e8fabd6ec44fe6aa971
Author: Poornima <pgurusid@redhat.com>
Date:   Fri Oct 11 04:06:56 2013 +0000

    gfapi: Fix iobuf leaks in gfapi
    
    In glfs_readv, if syncop_readv() fails with return value <= 0
    the iobref was not being unrefd which would cause iobuf leaks.
    
    Change-Id: I9850ae149e53cf75ba26f8b5f4c5446cce4b5991
    BUG: 1018176
    Signed-off-by: Poornima <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/6074
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Anand Avati 2013-11-26 13:39:47 EST
COMMIT: http://review.gluster.org/6324 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit fdf3d652acbbe6aa145b7dccd193392b9d1581bd
Author: Poornima <pgurusid@redhat.com>
Date:   Fri Oct 11 04:06:56 2013 +0000

    gfapi: Fix iobuf leaks in gfapi
    
    In glfs_readv, if syncop_readv() fails with return value <= 0
    the iobref was not being unrefd which would cause iobuf leaks.
    
    Change-Id: I9850ae149e53cf75ba26f8b5f4c5446cce4b5991
    BUG: 1018176
    Signed-off-by: Poornima <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/6324
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:49:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.