Bug 1018181 - Version module should be reloaded on-the-fly when installing patch bundle
Version module should be reloaded on-the-fly when installing patch bundle
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Patching (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER7
: EAP 6.2.0
Assigned To: Emanuel Muckenhuber
Jan Martiska
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 07:44 EDT by Jan Martiska
Modified: 2013-12-15 11:19 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:19:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
emuckenh: needinfo+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2296 Major Resolved Patched state is missing the updated resulting version 2013-11-01 06:58:56 EDT

  None (edit)
Description Jan Martiska 2013-10-11 07:44:46 EDT
If a patch bundle contains patches which change the EAP's version string (updates the org.jboss.as.product module), the version module needs to be reloaded after the installation of every single patch in the bundle, because the following patch in the bundle might have the prerequisite "applies-to" version equal to the one from the previous patch. 

Without this, it is impossible to apply a patch bundle which updates GA->CP1->CP2, because during installation of the second (CP1-CP2) patch, AS will still think that its version is GA and will reject the patch.

Found against upstream, but reporting against EAP, because quite obviously, this bug will be present in ER6 when it is built. The currently latest, ER5, does not support patch bundles at all.
Comment 1 Dimitris Andreadis 2013-10-15 08:50:02 EDT
Emanuel, is there an associated upstream JIRA?
Comment 3 JBoss JIRA Server 2013-10-25 15:59:16 EDT
Emanuel Muckenhuber <emuckenh@redhat.com> updated the status of jira WFLY-2296 to Resolved
Comment 4 Jan Martiska 2013-11-01 06:58:47 EDT
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.