Bug 1018209 - NPE while creating a deployment unit for an uploaded kjar
NPE while creating a deployment unit for an uploaded kjar
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Toni Rikkola
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 09:03 EDT by Ivo Bek
Modified: 2014-08-06 16:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Evaluation project in kjar (7.02 KB, application/x-java-archive)
2013-10-11 09:03 EDT, Ivo Bek
no flags Details
server log containing the NPE (15.16 KB, text/x-log)
2013-10-11 09:04 EDT, Ivo Bek
no flags Details

  None (edit)
Description Ivo Bek 2013-10-11 09:03:26 EDT
Created attachment 811092 [details]
Evaluation project in kjar

Description of problem:

The NPE is thrown when I create deployment unit for an uploaded kjar in business central,

The business central only says "Deployment of unit org.jbpm:Evaluation:1.0 failed: null" but the server log is much more interesting; I will attach it.

How reproducible:

configuration: install bpms-6.0.ER3 with eap 6.1.0.

Steps to Reproduce:
1. upload the attached kjar
2. notice following output in server log:

14:42:29,854 INFO  [stdout] (http-localhost/127.0.0.1:8080-2) GROUP_ID:
14:42:29,854 INFO  [stdout] (http-localhost/127.0.0.1:8080-2) ARTIFACT_ID:
14:42:29,854 INFO  [stdout] (http-localhost/127.0.0.1:8080-2) VERSION_ID:

3. create the deployment unit because it's probably not created during the upload of kjar:

groupId = org.jbpm
artifactId = Evaluation
version = 1.0

4. see exceptions in server log
Comment 1 Ivo Bek 2013-10-11 09:04:31 EDT
Created attachment 811093 [details]
server log containing the NPE
Comment 2 Ivo Bek 2013-12-05 08:42:28 EST
Verified in BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.