Bug 1018238 - JavaException and failed install with "can't connecto to 127.0.0.1:6999" error
JavaException and failed install with "can't connecto to 127.0.0.1:6999" error
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
x86_64 Linux
unspecified Severity low
: ER02
: JON 3.3.0
Assigned To: Stefan Negrea
Mike Foley
:
Depends On: 1096923
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 10:19 EDT by Deon Ballard
Modified: 2014-12-11 09:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:04:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2013-10-11 10:19:03 EDT
Description of problem:
I ran the rhqctl script to install the JON server, and the installation process failed when setting up the server, apparently at the point where it was trying to set up the monitoring schema. It had a Java error that it could not connect to 127.0.0.1:6999.

**** This happened for me twice in a row, but I tested this morning on a clean RHEL 6.4 beaker machine, and it worked fine. I am filing this as a record, not an urgent issue.

Version-Release number of selected component (if applicable):
JON 3.2 ER3 build from brew

How reproducible:
Intermittent. It happened to me twice in a row, and now has worked as expected 3 times in a row.

Steps to Reproduce:
From my history:

   77  cd /opt/
   78  mkdir jon
   79  wget http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.2.0.ER3/1/maven/org/jboss/on/jon-server/3.2.0.ER3/jon-server-3.2.0.ER3.zip
   80  wget http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.2.0.ER3/1/maven/org/jboss/on/jon-plugin-pack-eap/3.2.0.ER3/jon-plugin-pack-eap-3.2.0.ER3.zip
   81  wget http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.2.0.ER3/1/maven/org/jboss/on/jon-plugin-pack-fuse/3.2.0.ER3/jon-plugin-pack-fuse-3.2.0.ER3.zip
   82  unzip --help
   83  unzip jon-server-3.2.0.ER3.zip -d jon/
   84  sudo passwd postgres
   85  service postgresql initdb ; service postgresql start ; su - postgres
   86  vim /var/lib/pgsql/data/pg_hba.conf
   87  service postgresql restart
   88  export JAVA_HOME=/usr
   89  cd jon
   90  ls
   91  cd jon-server-3.2.0.ER3/
   92  ls
   93  cd bin/
   94  ls
   95  ./rhq-encode-password.sh
   96  vim rhq-server.properties
   97  ./rhqctl install --start


Actual results:
It failed with a Java exception that said something about not being able to connect to 127.0.0.1:6999. After that error, the install process stopped. The storage server was not installed/configured (the rhq-data/ directory existed, but was empty), and the agent install process never started.

It was the same error both times. The third time I tried it, I edited the standalone-full.xml file before running rhqctl, and the install went fine. (I have subsequently tried it twice just running rhqctl without editing anything first, and it has gone as expected, so I have no explanation for what went wrong.)

Additional info:
Unfortunately, I didn't save the install logs from my two failed attempts. 

I don't seem to have anything else installed (no JBoss products, no IPA), so there shouldn't be any postgres or port issues.
Comment 1 Simeon Pinder 2013-11-08 09:41:30 EST
Moving to unspecified target milestone as only JON 3.2.0 'blockers'(https://url.corp.redhat.com/bz-jon32-blockers-list-notmodified-nodocs) will make it into subsequent builds after ER5.
Comment 4 Stefan Negrea 2014-08-29 17:12:35 EDT
This bug is really old and was opened against ER3 of JON 3.2.0. A more recent fix addresses some problems around running the installer multiple times. Please look at bug 1096923 for more details. 

This issue is ready for testing as there is no evidence the problem is still persisting.
Comment 5 Simeon Pinder 2014-09-03 16:31:42 EDT
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194

Note You need to log in before you can comment on or make changes to this bug.