Bug 1018277 - Loading dashboard with widget removed causes traceback
Loading dashboard with widget removed causes traceback
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Elyézer Rezende
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 11:27 EDT by Justin Sherrill
Modified: 2014-05-13 10:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-13 10:29:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-10-11 11:27:10 EDT
Description of problem:

This is more of a dev issue, but if you load a katello branch with 5 widgets and then load another with only 4 widgets, you will get an error when the user preferences are loaded to display the widgets:

For example:

 uninitialized constant Dashboard::SystemGroupsWidget  

This shouldn't affect mdp2 at all, but affects devs as they switch code branches but don't clear the db, or will affect katello/satellite if we ever remove a widget.
Comment 1 RHEL Product and Program Management 2013-10-11 11:55:03 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Justin Sherrill 2013-10-14 10:39:37 EDT
not really an mdp2 critical feature

https://github.com/Katello/katello/pull/3167
Comment 4 Justin Sherrill 2013-10-16 15:45:39 EDT
since this has been moved to mdp3, no cherry picking should be required.
Comment 6 Elyézer Rezende 2014-05-13 10:29:29 EDT
Upgrades is not supported and also this is a bug that affects the dev environment as stated on bug's description.

Note You need to log in before you can comment on or make changes to this bug.