Bug 1018283 - "Infrastructure Server" installation option does not list FreeIPA under add-ons
"Infrastructure Server" installation option does not list FreeIPA under add-ons
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-10-11 11:38 EDT by Stephen Gallagher
Modified: 2013-10-14 15:28 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 15:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
F20 Beta TC2 software selection screenshot (130.64 KB, image/png)
2013-10-14 15:28 EDT, David Shea
no flags Details

  None (edit)
Description Stephen Gallagher 2013-10-11 11:38:43 EDT
Description of problem:
When installing Fedora 20 Beta TC2, I selected "Infrastructure Server" and was not presented with an option under Add-Ons to install a FreeIPA domain controller.

Version-Release number of selected component (if applicable):
Fedora 20 Beta TC2 from http://dl.fedoraproject.org/pub/alt/stage/20-Beta-TC2/Fedora/x86_64/os/

How reproducible:
Every time

Steps to Reproduce:
1. Boot the installer from the network (I did this in a VM)
2. Click on "Software Selection"
3. Click the radio button for "Infrastructure Server"

Actual results:
The list of add-ons neglects FreeIPA.

Expected results:
FreeIPA should be listed.

Additional info:
Comment 1 Fedora Blocker Bugs Application 2013-10-14 13:31:41 EDT
Proposed as a Freeze Exception for 20-final by Fedora user sgallagh using the blocker tracking app because:

 Not making this change before F20 Final means that users will not be able to install a targeted FreeIPA server directly from install media. This would be best fixed before release.
Comment 2 David Shea 2013-10-14 15:28:34 EDT
Created attachment 812201 [details]
F20 Beta TC2 software selection screenshot

It's available using a network repo. It's not available on the install DVD because the freeipa isn't on the install DVD (or at least the freeipa-server group isn't defined on the comps.xml on the install DVD).

Note You need to log in before you can comment on or make changes to this bug.