Bug 1018296 - Phreak mode does not evaluate 'from collect' correctly
Phreak mode does not evaluate 'from collect' correctly
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Mario Fusco
Marek Winkler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 11:56 EDT by Mario Fusco
Modified: 2014-08-06 16:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DROOLS-295 Major Resolved Phreak mode does not evaluate 'from collect' correctly. 2013-12-12 12:23:17 EST

  None (edit)
Description Mario Fusco 2013-10-11 11:56:12 EDT
Reproducer project at: https://github.com/DuncanDoyle/Drools6PhreakFromCollectIssue

Run 'mvn clean test'. There are 2 tests which execute exactly the same thing against the same ruleset, one in ReteOO mode and one in Phreak. The result of the Phreak test is incorrect. There seems to be an issue with the 'from collect' in Phreak mode.
Comment 2 Mario Fusco 2013-10-11 12:02:58 EDT
Fixed by https://github.com/droolsjbpm/drools/commit/d4ff4d31f
Comment 3 Mario Fusco 2013-10-11 12:04:16 EDT
Fixed by https://github.com/droolsjbpm/drools/commit/d4ff4d31f
Comment 4 JBoss JIRA Server 2013-10-11 12:05:30 EDT
Mario Fusco <mario.fusco@gmail.com> updated the status of jira DROOLS-295 to Resolved
Comment 5 Marek Winkler 2013-12-12 12:11:04 EST
Verified on BRMS 6.0.0 ER5.

Note You need to log in before you can comment on or make changes to this bug.