Bug 1018297 - "Wrong settings detected for Bugzilla" message is inappropriate when user has chosen not to save their password
"Wrong settings detected for Bugzilla" message is inappropriate when user has...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 11:56 EDT by Matthew Garrett
Modified: 2016-11-30 19:45 EST (History)
9 users (show)

See Also:
Fixed In Version: gnome-abrt-0.3.3-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:39:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Garrett 2013-10-11 11:56:27 EDT
Reporting a bug via ABRT always pops up a dialog saying"

"Wrong settings detected for Bugzilla, reporting will probably fail if you continue with the current configuration."

In fact, this is because I've chosen not to save my password. This isn't a "Wrong setting" - in this case ABRT should simply prompt me for my password, not give me a scary warning and then show me the full Bugzilla configuration dialog
Comment 1 Jakub Filak 2013-10-17 09:44:08 EDT
I've created a pull request with patches supposed to fix this issue.

https://github.com/abrt/libreport/pull/191
Comment 2 Fedora Update System 2013-10-30 10:23:26 EDT
gnome-abrt-0.3.3-1.fc20, abrt-2.1.9-1.fc20, libreport-2.1.9-1.fc20, satyr-0.11-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-20254/gnome-abrt-0.3.3-1.fc20,abrt-2.1.9-1.fc20,libreport-2.1.9-1.fc20,satyr-0.11-1.fc20
Comment 3 lnie 2013-11-05 02:37:23 EST
didn't saw this bug with the packages above
Comment 4 Fedora Update System 2013-11-05 15:00:45 EST
Package gnome-abrt-0.3.3-2.fc20, abrt-2.1.9-1.fc20, libreport-2.1.9-1.fc20, satyr-0.11-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.3-2.fc20 abrt-2.1.9-1.fc20 libreport-2.1.9-1.fc20 satyr-0.11-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20254/gnome-abrt-0.3.3-2.fc20,abrt-2.1.9-1.fc20,libreport-2.1.9-1.fc20,satyr-0.11-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-10 01:39:41 EST
gnome-abrt-0.3.3-2.fc20, abrt-2.1.9-1.fc20, libreport-2.1.9-1.fc20, satyr-0.11-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.