Bug 1018327 - ipsec.conf man page lacks example for AES-GCM configuration
ipsec.conf man page lacks example for AES-GCM configuration
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openswan (Show other bugs)
6.5
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Paul Wouters
Aleš Mareček
:
Depends On:
Blocks: 1162770
  Show dependency treegraph
 
Reported: 2013-10-11 13:28 EDT by Hubert Kario
Modified: 2014-11-11 11:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1162770 (view as bug list)
Environment:
Last Closed: 2014-10-14 04:18:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
replacement phase2alg.xml (1.52 KB, text/xml)
2014-02-13 23:15 EST, Paul Wouters
no flags Details

  None (edit)
Description Hubert Kario 2013-10-11 13:28:02 EDT
Description of problem:
The encryption configuration with AES-GCM is not described in ipsec.conf man page

Version-Release number of selected component (if applicable):
openswan-2.6.32-25.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. man ipsec.conf | col -b | grep aes_gcm

Actual results:
*nothing found*

Expected results:
example with valid phase2 algorithms, e.g.:
phase2alg=aes_gcm_a-224-null


Additional info:
Comment 1 RHEL Product and Program Management 2013-10-14 21:34:02 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Paul Wouters 2014-02-13 23:15:04 EST
Attached the updated phase2alg.xml file. This can be replace the openswan version on the next openswan update we do. Sorry we missed it on this one.
Comment 4 Paul Wouters 2014-02-13 23:15:40 EST
Created attachment 863088 [details]
replacement phase2alg.xml

replacement phase2alg.xml
Comment 5 Hubert Kario 2014-02-14 05:27:09 EST
(In reply to Paul Wouters from comment #4)
> Created attachment 863088 [details]
> replacement phase2alg.xml
> 
> replacement phase2alg.xml

Looks good.

One extra thing, since it's in the same section of man page. Would it be possible to list the available DH group sizes explicitly?
While RFC5114  does list some parameters, it doesn't say which is which (e.g. doesn't say that the dh1 is 768bit, dh2 is 1024, etc.). Higher group sizes like 1536 bit or 2048 bit are even harder to find...
Comment 6 Hubert Kario 2014-02-14 05:30:34 EST
spelling:

> adding the salt size to the key size. Therefor, to interop with an older

s/Therefor/Therefore/

it probably should also be interoperate, not interop

> are necessarilly supported here.</para>

s/necessarilly/necessarily/
Comment 10 errata-xmlrpc 2014-10-14 04:18:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1588.html

Note You need to log in before you can comment on or make changes to this bug.