Bug 1018349 - rhqclt does not propagate RHQ_CONTROL_ADDITIONAL_JAVA_OPTS to JON VM
rhqclt does not propagate RHQ_CONTROL_ADDITIONAL_JAVA_OPTS to JON VM
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Launch Scripts (Show other bugs)
JON 3.2
x86_64 Linux
urgent Severity medium
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 14:24 EDT by Viet Nguyen
Modified: 2014-01-07 10:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-07 10:32:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viet Nguyen 2013-10-11 14:24:26 EDT
I wanted to customize server jvm settings with RHQ_CONTROL_ADDITIONAL_JAVA_OPTS="-verbosegc -XX:+PrintGCDateStamps -XX:+PrintGCTimeStamps -XX:+PrintGCDetails -Xloggc:/tmp/rhq-server-gc.log"

However gc log file only shows a summary of gc activities which I suspect belongs to rhqctl process not jon server's. 

Build
ER3

How reproducible:
100%

Steps to Reproduce:
1.  export RHQ_CONTROL_ADDITIONAL_JAVA_OPTS=-Dfoobar
2.  rhqctl restart (or start)
3.  ps -ef|grep jav[a]

Actual results:

No sight of -Dfoobar in jon server vm arguments 


Expected results:


Additional info:
Comment 1 Viet Nguyen 2013-10-11 14:47:40 EDT
Upon further investigation I found the old RHQ_AGENT_ADDITIONAL_JAVA_OPTS and RHQ_SERVER_ADDITIONAL_JAVA_OPTS still work as designed.  Since rhqclt is now the one stop script we should include the usage for RHQ_SERVER.. and RHQ_AGENT..
Comment 2 Simeon Pinder 2013-11-08 09:41:06 EST
Moving to unspecified target milestone as only JON 3.2.0 'blockers'(https://url.corp.redhat.com/bz-jon32-blockers-list-notmodified-nodocs) will make it into subsequent builds after ER5.
Comment 4 Libor Zoubek 2014-01-07 09:50:09 EST
We'd need to get this fixed at least in RHQ, it's blocking our code coverage job. Thanks
Comment 5 John Mazzitelli 2014-01-07 10:03:16 EST
these should not propogate to the JON VM - the name RHQ_CONTROL_... means its only for the rhqctl java code (that is, its only for the JVM for the control script).
Comment 6 John Mazzitelli 2014-01-07 10:06:37 EST
However, I think what this BZ is asking for is - now that we have this wrapper JVM thingy "rhqctl" - we probably need a way for propogate custom environment settings to the server / agent JVM right?

Doesn't setting the normal env vars still work? RHQ_SERVER_xxx and RHQ_AGENT_xxx ??? If they still work, then this BZ can be closed as "working as expected"

If there is no way to customize the server and agent JVM through those normal env var mechanisms, we need to figure out how to do so.
Comment 7 Libor Zoubek 2014-01-07 10:32:59 EST
I thought I was hitting this bug, but it turned out I'm not. As RHQ_CONTROL_ are suposed to be for rhqctl JVM and RHQ_AGENT_ and RHQ_SERVER_ work as expected, closing

Note You need to log in before you can comment on or make changes to this bug.