Bug 1018418 - older usbmuxd is not erased after updating via yum
older usbmuxd is not erased after updating via yum
Status: CLOSED DUPLICATE of bug 1017493
Product: Fedora
Classification: Fedora
Component: usbmuxd (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 19:21 EDT by RudraB
Modified: 2013-10-12 06:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 06:33:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RudraB 2013-10-11 19:21:45 EDT
Description of problem:
Older usbmuxd is not erased after updating via yum. So, all older release is still in machine. Can't explicitely delete either.

Version-Release number of selected component (if applicable):
Name        : usbmuxd
Arch        : x86_64
Version     : 1.0.8


How reproducible:


Steps to Reproduce:
1.update fedora20 
2.
3.

Actual results:
Older usb is still present in the system.
$ rpm -qa|grep usbmuxd
usbmuxd-1.0.8-10.fc20.x86_64
usbmuxd-1.0.8-9.fc20.x86_64
usbmuxd-1.0.8-8.fc20.x86_64

Expected results:
Should have only one usbmuxd, I guess.

Additional info:
usbmuxd info from yum:
Finishing delta rebuilds of 17 package(s) (49 M)
/var/cache/yum/x86_64/20/updates-testing/packages/usbmuxd-1.0.8-8.fc20_1.0.8-10.fc20.x86_64.drpm: md5 mismatch of result
Some delta RPMs failed to download or rebuild. Retrying..|  49 MB     00:00 ETA 
usbmuxd-1.0.8-10.fc20.x86_64.rpm            
..........
..........
/var/tmp/rpm-tmp.di9cQM: line 1: fg: no job control
error: %preun(usbmuxd-1.0.8-9.fc20.x86_64) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package usbmuxd
error: usbmuxd-1.0.8-9.fc20.x86_64: erase failed

usbmuxd-1.0.8-9.fc20.x86_64 was supposed to be removed but is not!
usbmuxd-1.0.8-8.fc20.x86_64 was supposed to be removed but is not!
Failed:
  usbmuxd.x86_64 0:1.0.8-8.fc20          usbmuxd.x86_64 0:1.0.8-9.fc20
Comment 1 Peter Robinson 2013-10-12 06:33:10 EDT

*** This bug has been marked as a duplicate of bug 1017493 ***

Note You need to log in before you can comment on or make changes to this bug.