Bug 1018425 - Application icon does not scale well
Application icon does not scale well
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 19:43 EDT by Jorn Baayen
Modified: 2014-02-15 01:57 EST (History)
2 users (show)

See Also:
Fixed In Version: lyx-2.0.7-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-15 01:56:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jorn Baayen 2013-10-11 19:43:24 EDT
The Lyx application icon does not scale well, and looks blurry in the Gnome 3 dock.

It is suggested that one of the SVG icons from

  http://wiki.lyx.org/LyX/Icons

is packaged instead.
Comment 1 José Matos 2014-02-04 11:27:32 EST
I will forward this request to the lyx developers list.

When it is applied upstream we will package it for Fedora.
Comment 2 José Matos 2014-02-04 12:37:33 EST
Right, we already package lyx.svg. :-)

Rex, should we add in the icon part something like:

install -p -D -m644 lib/images/lyx.svg \
  %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/lyx.svg

?

I suspect that this should be enough, no?
Comment 3 Fedora Update System 2014-02-05 19:02:38 EST
lyx-2.0.7-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lyx-2.0.7-3.fc20
Comment 4 Fedora Update System 2014-02-05 19:15:52 EST
lyx-2.0.7-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lyx-2.0.7-3.fc19
Comment 5 Rex Dieter 2014-02-06 11:58:43 EST
Sorry for delay, but yeah, that looks like a good change/fix.
Comment 6 José Matos 2014-02-06 15:57:46 EST
No problem. :-)
I found the freedesktop spec for icons while getting some research for a lyx-devel discussion. That was how I got confident to commit the change.
Comment 7 Fedora Update System 2014-02-06 22:12:03 EST
Package lyx-2.0.7-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lyx-2.0.7-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2125/lyx-2.0.7-3.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-02-15 01:56:32 EST
lyx-2.0.7-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-02-15 01:57:47 EST
lyx-2.0.7-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.