Bug 1018452 - Typo in man page of edit-node of the explanation of --install-kmod
Typo in man page of edit-node of the explanation of --install-kmod
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-12 03:36 EDT by wanghui
Modified: 2014-01-21 14:54 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-4.el6
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:54:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20161 None None None Never

  None (edit)
Description wanghui 2013-10-12 03:36:55 EDT
Description of problem:
There is a typo in man page of edit-node. It should be kmod package instead of plugin package in the explanation of --install-kmod usage.

Version-Release number of selected component (if applicable):
ovirt-node-tools-3.0.1-3.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install ovirt-node-tools-3.0.1-3.el6.noarch.
2. check the man page of edit-node.

Actual results:
1.There is a typo error in the explanation of --install-komd.
  The output is as follows:
  --install-kmod=KMOD_PACKAGE_NAME
              Installs a the specific plugin package from a yum repo or speci-
              fied rpm file, valid file locations are whitelisted to kmod spe-
              cific areas.  Multiple packages can be specified by comma delim-
              ited list (package1,package2)

  It should be kmod package not plugin package in the first line.

Expected results:
1. The output should be like the follows:
   --install-kmod=KMOD_PACKAGE_NAME
              Installs a the specific kmod package from a yum repo or speci-
              fied rpm file, valid file locations are whitelisted to kmod spe-
              cific areas.  Multiple packages can be specified by comma delim-
              ited list (package1,package2)

Additional info:
Comment 4 wanghui 2013-10-21 07:52:07 EDT
Test version:
ovirt-node-3.0.1-4.el6.noarch
ovirt-node-tools-3.0.1-4.el6.noarch

Test steps:
1. Install ovirt-node-tools-3.0.1-3.el6.noarch.
2. check the man page of edit-node.

Test results:
1. The output is as the follows.
   --install-kmod=KMOD_PACKAGE_NAME
              Installs a the specific kmod package from a yum repo or speci-
              fied rpm file, valid file locations are whitelisted to kmod spe-
              cific areas.  Multiple packages can be specified by comma delim-
              ited list (package1,package2)


The bug is fixed in rhev-hypervisor6-6.5-20131017.0.iso. So change the bug's status from ON_QA to VERIFIED.
Comment 7 Cheryn Tan 2013-11-07 19:34:41 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 9 errata-xmlrpc 2014-01-21 14:54:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.