Bug 1018457 - Miss install OpenIPMI during installing ovirt-node-plugin-ipmi and start ipmi service when loading IPMI page
Miss install OpenIPMI during installing ovirt-node-plugin-ipmi and start ipmi...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 3.4.0
Assigned To: Ryan Barry
bugs@ovirt.org
node
:
Depends On: 1018456
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-12 04:37 EDT by haiyang,dong
Modified: 2014-03-31 08:23 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1018456
Environment:
Last Closed: 2014-03-31 08:23:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for IPMI page (15.59 KB, image/png)
2013-10-12 04:41 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20129 None None None Never

  None (edit)
Description haiyang,dong 2013-10-12 04:37:57 EDT
+++ This bug was initially created as a clone of Bug #1018456 +++

Description of problem:
Using "edit-node --repo=edit-node.repo --install=ovirt-node-plugin-ipmi-3.0.1-3.el6.noarch.rpm rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
" to install ipmi plugin into rhev-h.
It just install ovirt-node-plugin-ipmi and ipmitool package. Miss install OpenIPMI and OpenIPMI-libs package.
Then clean install rhev-hypervisor6-6.5-20130930.0.auto665.ipmi.el6.iso on DELL PowerEdge R510,login rhev-h.
Enter into IPMI page and check that IPMI Enabled is False.

Also drop into shell and check that:
[root@dell-per510-01 ~]# ipmitool -I open sdr elist full
Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directory
Get Device ID command failed
Unable to open SDR for reading

The root cause is due to miss install OpenIPMI during installing ovirt-node-plugin-ipmi
and miss to start ipmi service when loading IPMI page.


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso        
ovirt-node-3.0.1-3.el6.noarch
ovirt-node-tools-3.0.1-3.el6.noarch.rpm
ovirt-node-plugin-ipmi-3.0.1-3.el6.noarch.rpm


How reproducible:
100%

Steps to Reproduce:


Actual results:

Expected results:


Additional info:
Comment 1 haiyang,dong 2013-10-12 04:39:47 EDT
This issue also reproduce on ovirt-node upstream, so need to clone it form ovirt-node downstream to track it
Comment 2 haiyang,dong 2013-10-12 04:41:31 EDT
Created attachment 811524 [details]
attached Screenshot for IPMI page

After add OpenIPMI Requires and start ipmi service when loading IPMI page.
Now the "IPMI Enabled" show "True" and Fan Status also was shown in IPMI page.(Seen attached Screenshot for IPMI page)
http://gerrit.ovirt.org/#/c/20129/
Comment 3 Sandro Bonazzola 2014-01-27 08:50:31 EST
This should be fixed in oVirt 3.4.0 beta1 build
Comment 4 haiyang,dong 2014-03-03 03:07:03 EST
Test version:
ovirt-node-iso-3.0.4-1.0.201401291204.el6.iso
ovirt-node-plugin-ipmi-3.0.4-1.0.el6.noarch.rpm
ovirt-node-tools-3.0.4-1.0.el6.noarch.rpm

Using "edit-node --repo=edit-node.repo --install=ovirt-node-plugin-ipmi-3.0.4-1.0.el6.noarch.rpm ovirt-node-iso-3.0.4-1.0.201401291204.el6.iso
" to install ipmi plugin into ovirt-node iso.
It will install ovirt-node-plugin-ipmi ipmitool OpenIPMI and OpenIPMI-libs package.
Then clean install this edited iso on DELL PowerEdge R510,login ovirt-node iso.
Enter into IPMI page and check that the "IPMI Enabled" show "True" and Fan Status also was shown in IPMI page.
Also default ipmi service will start during booting.

so this bug has been fixed, change it into "VERIFIED".
Comment 5 Sandro Bonazzola 2014-03-31 08:23:24 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.