Bug 1018472 - [fork][origin_ui_82] Met undefined method `absolute_path' while deploy binary files
[fork][origin_ui_82] Met undefined method `absolute_path' while deploy binary...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-12 06:53 EDT by Xiaoli Tian
Modified: 2013-10-17 09:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: fork_ami_origin_ui_82_902
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:35:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2013-10-12 06:53:26 EDT
Description of problem:

While trying to deploy  app with binary type, will meet the following errors
 
#rhc deploy -a phps --ref deployment.tar
/usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/deployment_helpers.rb:28:in `deploy_file': undefined method `absolute_path' for File:Class (NoMethodError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/commands/app.rb:386:in `deploy'
           ------
	from /usr/bin/rhc:19:in `load'
	from /usr/bin/rhc:19



Version-Release number of selected component (if applicable):
rhc built from fork_ami_origin_ui_82_899

How reproducible:
Always

Steps to Reproduce:
1.Create an app and set the deployment type to binary, check it's in binary deployment type
#rhc app-show --configuration -a phps
phps @ http://phps-domx1.dev.rhcloud.com/ (uuid: 52591d3a1ddee2006100002c)
--------------------------------------------------------------------------
  Deployment:        manual (use 'rhc deploy')
  Keep Deployments:  3
  Deployment Type:   binary
  Deployment Branch: master

Use 'rhc configure-app' to change the configuration values of this application

2. Get one binary tar file by 
#ssh 2591d3a1ddee2006100002c@phps-domx1.dev.rhcloud.com 'gear archive-deployment' >deployment.tar

3.Deploy the binary file:
#rhc deploy -a phps --ref /root/deployment.tar

Actual results:
#rhc deploy -a phps --ref deployment.tar
/usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/deployment_helpers.rb:28:in `deploy_file': undefined method `absolute_path' for File:Class (NoMethodError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/commands/app.rb:386:in `deploy'
	from /usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/commands.rb:285:in `send'
	from /usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/commands.rb:285:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/commands.rb:276:in `to_commander'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/runner.rb:383:in `run_active_command'
	from /usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/command_runner.rb:73:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/delegates.rb:7:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/lib/rhc/cli.rb:37:in `start'
	from /usr/lib/ruby/gems/1.8/gems/rhc-1.16.0/bin/rhc:20
	from /usr/bin/rhc:19:in `load'
	from /usr/bin/rhc:19


Expected results:
It should  be able to deploy binary file successfully via rhc


Additional info:
Comment 1 Wei Sun 2013-10-14 04:31:23 EDT
Tested this bug on fork_ami_origin_ui_82_902,could not reproduce this bug now.

dhcp-65-184:test OpenShift$ rhc deploy ./deployment.tar  -a phpt
Deployment of file '/Users/OpenShift/test/deployment.tar' in progress for application phpt ...
Success
Comment 2 Fabiano Franz 2013-10-14 10:15:30 EDT
Fixed in fork_ami_origin_ui_82_902.
Comment 3 weiwei jiang 2013-10-15 01:59:03 EDT
Tried on fork_ami_origin_ui_82_905, and it success, so verify this issue.

# rhc deploy -a app1 app.tar.gz
Deployment of file '/root/app.tar.gz' in progress for application app1 ...
Beginning binary deployment

Distribution status: success

Activation status: success

Deployment completed

Success

Note You need to log in before you can comment on or make changes to this bug.