Bug 1018474 - Can't set vm.nr_pdflush_threads= variable from kernel
Can't set vm.nr_pdflush_threads= variable from kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-12 07:28 EDT by Marian
Modified: 2013-10-12 08:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 08:42:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian 2013-10-12 07:28:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):
kernel 3.11.1-200.fc19.x86_64

How reproducible:


Steps to Reproduce:
1.Run as root sysctl -w vm.nr_pdflush_threads=1
2.sysctl -a 
3.

Actual results:
Variable vm.nr_pdflush_threads=0 

Expected results:
vm.nr_pdflush_threads=1

Additional info:
Comment 1 Josh Boyer 2013-10-12 08:42:29 EDT
That's because it's been obsolete for a while.  per-BDI flusher threads were introduced in 2.6 and pdflush isn't used anymore.  In 3.6, the following commit made the nr_pdflush_threads sysctl obsolete:

commit 3965c9ae47d64aadf6f13b6fcd37767b83c0689a
Author: Wanpeng Li <liwp@linux.vnet.ibm.com>
Date:   Tue Jul 31 16:41:52 2012 -0700

    mm: prepare for removal of obsolete /proc/sys/vm/nr_pdflush_threads
    
    Since per-BDI flusher threads were introduced in 2.6, the pdflush
    mechanism is not used any more.  But the old interface exported through
    /proc/sys/vm/nr_pdflush_threads still exists and is obviously useless.
    
    For back-compatibility, printk warning information and return 2 to notify
    the users that the interface is removed.
    
    Signed-off-by: Wanpeng Li <liwp@linux.vnet.ibm.com>
    Cc: Wu Fengguang <fengguang.wu@intel.com>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

Note You need to log in before you can comment on or make changes to this bug.