Bug 1018482 - [RFE] Pleas create EPEL-6 branch for the GUIless build of this component
[RFE] Pleas create EPEL-6 branch for the GUIless build of this component
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: libinfinity (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-12 08:34 EDT by Matěj Cepl
Modified: 2013-10-13 16:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-13 16:39:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch (3.67 KB, patch)
2013-10-12 08:34 EDT, Matěj Cepl
no flags Details | Diff

  None (edit)
Description Matěj Cepl 2013-10-12 08:34:06 EDT
Created attachment 811569 [details]
suggested patch

Description of problem:
infinoted could be useful even on RHEL-6 even though we cannot build GUI components there (unfortunately).

http://koji.fedoraproject.org/koji/taskinfo?taskID=6053262

Version-Release number of selected component (if applicable):
libinfinity-0.5.4-1.el6.src.rpm
Comment 1 Till Maas 2013-10-12 11:46:02 EDT
| %if 0%{?rhel} >= 7
Why is the comparison with '7' and not with '6'? And why is it working in koji?

Would you mind maintaining it for EPEL6? I won't use it there and would not notice bugs.
Comment 2 Matěj Cepl 2013-10-13 13:28:47 EDT
(In reply to Till Maas from comment #1)
> | %if 0%{?rhel} >= 7
> Why is the comparison with '7' and not with '6'? And why is it working in
> koji?

Because EL-7 will (hopefully) have enough gtk3 powers to allow building GUI?

> Would you mind maintaining it for EPEL6? I won't use it there and would not
> notice bugs.

Probably not. I have found out that actually gedit-collaboration plugin (which I planned to use the server with) is unmaintained and broken, so it doesn't work with infinoted-5.
Comment 3 Till Maas 2013-10-13 15:10:31 EDT
(In reply to Matěj Cepl from comment #2)
> (In reply to Till Maas from comment #1)
> > | %if 0%{?rhel} >= 7
> > Why is the comparison with '7' and not with '6'? And why is it working in
> > koji?
> 
> Because EL-7 will (hopefully) have enough gtk3 powers to allow building GUI?

Ah, yes, I confused bcond_with and without. It is clear to me now.
 
> > Would you mind maintaining it for EPEL6? I won't use it there and would not
> > notice bugs.
> 
> Probably not. I have found out that actually gedit-collaboration plugin
> (which I planned to use the server with) is unmaintained and broken, so it
> doesn't work with infinoted-5.

Ok.
Comment 4 Till Maas 2013-10-13 16:39:39 EDT
I applied your patch in GIT, therefore a branch for EPEL 6 is now easily possible. I will re-consider creating a branch when there is demand for it again.

Note You need to log in before you can comment on or make changes to this bug.